Subject: is the oracle client supposed to be owned by postgres or root?

From: Henry Ashu <[email-masked]>
Date: Thu, 12 Sep 2024 10:07:43 -0700

Please I want to migrate my Oracle database to Postgres, should the Oracle
client be own by the postgres user or root user?

Thank you

*Henry Ashu*

Database Administrator
*o:* 503.672.5114 | *f:* 800.551.8821 | DAT.com
 <https://www.dat.com/>    [image: Like us on
Facebook] <https://www.facebook.com/loadboards>  [image: Follow us on
Twitter] <https://twitter.com/loadboards>  [image: Connect with us on
LinkedIn] <https://www.linkedin.com/company/datsolutions>  [image: Visit
our YouTube Channel] <https://www.youtube.com/datloadboards>  [image: Visit
us on Instagram] <https://instagram.com/dat_solutions>

---

From: <[email-masked]>
Date: Thu, 12 Sep 2024 21:19:46 -0400

Postgres  can take

Use EDB migration took kit, that will most of the work for you

Here is url go through it

https://www.enterprisedb.com/products/migration-toolkit-move-oracle-postgresql

From: Henry Ashu <[email-masked]> 
Sent: Thursday, September 12, 2024 1:08 PM
To: [email-masked]
Subject: is the oracle client supposed to be owned by postgres or root?

Please I want to migrate my Oracle database to Postgres, should the Oracle client be own by the postgres user or root user?

Thank you

Henry Ashu

Database Administrator
o: 503.672.5114 | f: 800.551.8821 | DAT.com

 <https://www.dat.com/>      <https://www.facebook.com/loadboards>    <https://twitter.com/loadboards>    <https://www.linkedin.com/company/datsolutions>    <https://www.youtube.com/datloadboards>    <https://instagram.com/dat_solutions>

---

From: Muhammad Waqas <[email-masked]>
Date: Fri, 13 Sep 2024 09:45:16 +0500

Oracle Binaries and Oracle Database file should by own by oracle user and
oinstall group.

First you have to migrate objects from oracle to postgresql, In which you
can use ora2pg tool.and then migrate data.

On Thu, 12 Sept 2024 at 22:08, Henry Ashu <[email-masked]> wrote:

> our YouTube Channel] <https://www.youtube.com/datloadboards>  [image:
> Visit us on Instagram] <https://instagram.com/dat_solutions>
>

-- 
*Muhammad Waqas*
*Senior Technical Support Engineer - Tech Support Center (Karachi)*
Mobile: +92-322-2844150
Email:  [email-masked] <[email-masked]>*
1st floor, suit no F-04, COLABS Karachi, 8-C Khayaban-e-Tanzeem,
DHA Phase 5 Tauheed Commercial Area,
Defense V Defense Housing Authority, Karachi, Karachi City, Sindh,
75500 Pakistan.

---

From: Muhammad Ikram <[email-masked]>
Date: Fri, 13 Sep 2024 10:51:00 +0500

Hi Henry Ashu,

 EDB migration toolkit is good for data objects when the target is
community PostgreSQL. It won't be migrating code objects like procedures,
packages, functions etc. For PostgreSQL target one may opt Ora2pg.
If your target is EDB Postgres then EDB Migration toolkit is good and even
better is EDB's Migration Portal for schema migration, as it leverages to
correct DDLs online and reassess if these fail after Assessment and
conversion by Portal. Again for data you will have to use EDB Migration
toolkit.

Regards,
Muhammad Ikram

On Fri, Sep 13, 2024 at 9:45 AM Muhammad Waqas <[email-masked]> wrote:

>> Please I want to migrate my Oracle database to Postgres, should the
>> Oracle client be own by the postgres user or root user?
>>
>> Thank you
>>
>> *Henry Ashu*
>>
>> Database Administrator