Subject: Info on compile environment for RHEL 8 version of PG 17-2.1

From: "Hall, Michael H. (GSFC-423.0)[RAYTHEON COMPANY]" <[email-masked]>
Date: Fri, 20 Dec 2024 22:49:05 +0000

I’m a SysAdmin who has provided following packages to allow my DBA to transfer an Open Source compiled version of PG 13 to PG 17-2.1 installed from site RPMs.

The system in use has glibc v2.28-251 as provided by RH and recently patched (early Dec 2024).

Wondering if the version in repo is a newer version of Glibc based on some of the error messages.
Have reduced this list for length,  but seems like there may also be a related language type missing (libc.mo).

stat("/usr/pgsql-17/lib/tls/haswell/avx512_1", 0x7ffcf160eb30) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/pgsql-17/lib/tls/haswell/x86_64/libpthread.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/pgsql-17/lib/tls/haswell/x86_64", 0x7ffcf160eb30) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/pgsql-17/lib/tls/haswell/libpthread.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/pgsql-17/lib/tls/haswell", 0x7ffcf160eb30) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/pgsql-17/lib/tls/avx512_1/x86_64/libpthread.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/pgsql-17/lib/tls/avx512_1/x86_64", 0x7ffcf160eb30) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/pgsql-17/lib/tls/avx512_1/libpthread.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/pgsql-17/lib/tls/avx512_1", 0x7ffcf160eb30) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/pgsql-17/lib/tls/x86_64/libpthread.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)

openat(AT_FDCWD, "/usr/share/locale/en_US.UTF-8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/share/locale/en_US.utf8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/share/locale/en_US/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/share/locale/en.UTF-8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/share/locale/en.utf8/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/share/locale/en/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)

--
Michael H. “Mike” Hall, Sr.   NASA-GSFC
Cell:      410-370-5901           Working Remotely from Baltimore

---

From: "Hall, Michael H. (GSFC-423.0)[RAYTHEON COMPANY]" <[email-masked]>
Date: Tue, 24 Dec 2024 13:13:22 +0000

Since originally sending this for moderation, my DBA has reconfigured his LD_LIBRARY_PATH and verified some new options on pg_upgrade.
At last report, he had converted this databases to PG17-2.
Have a happy and quiet holiday everyone.

From: "Hall, Michael H. (GSFC-423.0)[RAYTHEON COMPANY]" <[email-masked]>
Date: Tuesday, December 24, 2024 at 7:10 AM
To: "[email-masked]" <[email-masked]>
Subject: Info on compile environment for RHEL 8 version of PG 17-2.1

---

From: Tom Lane <[email-masked]>
Date: Tue, 24 Dec 2024 11:04:57 -0500

> Wondering if the version in repo is a newer version of Glibc based on some of the error messages.

What error messages?  The strace output you show just looks like the
program running through predefined search paths for libraries and
localization data.

In any case, when you don't say exactly what packages you're trying
to install or where you got them from, it's quite hard to say if
they're supposed to be compatible with RHEL8.

			regards, tom lane