Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1itvTa-0002O4-Vp for pgsql-admin@arkaria.postgresql.org; Tue, 21 Jan 2020 15:29:59 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1itvTZ-0007IL-Im for pgsql-admin@arkaria.postgresql.org; Tue, 21 Jan 2020 15:29:57 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1itvTZ-0007IC-2H; Tue, 21 Jan 2020 15:29:57 +0000 Received: from momjian.us ([72.94.173.45]) by makus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1itvTW-0005WV-G7; Tue, 21 Jan 2020 15:29:55 +0000 Received: from bruce by momjian.us with local (Exim 4.92) (envelope-from ) id 1itvTV-0007Yq-VC; Tue, 21 Jan 2020 10:29:53 -0500 Date: Tue, 21 Jan 2020 10:29:53 -0500 From: Bruce Momjian To: Shrikant Bhende Cc: pgsql-admin@lists.postgresql.org, pgsql-admin@postgresql.org Subject: Re: pg_upgrade from 9.5 to 12 fails due to plpythonu2 Message-ID: <20200121152953.GA7083@momjian.us> References: MIME-Version: 1.0 Content-Type: text/plain; charset=iso-8859-1 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: User-Agent: Mutt/1.10.1 (2018-07-13) List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk On Tue, Jan 21, 2020 at 03:00:24PM +0530, Shrikant Bhende wrote: > Hello, > > I am trying to upgrade a PostgreSQL cluster running on version 9.5 to 12, most > of the code is written in the form of procedures using pl/python (version 2 and > version 3), while running pg_upgrade I am getting below error,  > > "Your installation references loadable libraries that are missing from the > new installation.  You can add these libraries to the new installation, > or remove the functions using them from the old installation.  A list of > problem libraries is in the file: >     loadable_libraries.txt" > > Old installation uses both the versions of plpython (2 and 3 and I am getting > error for 2 which is not supported in 12. > > Contents of loadable_libraries.txt  > > could not load library "$libdir/plpython2": ERROR:  could not access file > "$libdir/plpython2": No such file or directory > Database: cctest > Database: master > Database: postgres > Database: vmware > could not load library "$libdir/plugin_debugger": ERROR:  could not access file > "$libdir/plugin_debugger": No such file or directory > Database: vmware > > I have tried to install plpython2 with PostgreSQL 12 but I guess that's not > supported, also I am not able to find out anything related to debugging in > PostgreSQL. > What will be the efficient way to upgrade from 9.5 to 12 with plpython2 > dependency in the code? Well, I am guessing you will need to remove the use of plpython 2 from 9.5 and then do the upgrade. However, the community still supports Python 2 in PG 12: https://www.postgresql.org/docs/12/plpython-python23.html so it must be your package manager that doesn't support it or something. -- Bruce Momjian http://momjian.us EnterpriseDB http://enterprisedb.com + As you are, so once was I. As I am, so you will be. + + Ancient Roman grave inscription +