Subject: measuring WAL creation

From: Scott Ribe <[email-masked]>
Date: Fri, 2 Aug 2024 13:16:06 -0600

I'd like to measure both the amount of WAL created by a long series of data modifications and the compressed size of the generated WAL files.

I suppose I need to set wal_keep_size high, and pay attention to segment numbers to make sure it was high enough. Then I can look at segments created while the commands were running.

But question: can I simply delete all WAL after a clean shutdown?

--
Scott Ribe
[email-masked]
https://www.linkedin.com/in/scottribe/

---

From: Tom Lane <[email-masked]>
Date: Fri, 02 Aug 2024 16:29:19 -0400

> But question: can I simply delete all WAL after a clean shutdown?

As a general rule, never do that manually --- the risk/reward ratio is
unattractive.  A checkpoint will release all safely-releasable WAL.
You can checkpoint via a shutdown if you insist, but a plain
CHECKPOINT command should be enough.

			regards, tom lane

---

From: Scott Ribe <[email-masked]>
Date: Fri, 2 Aug 2024 15:13:16 -0600

> On Aug 2, 2024, at 2:29 PM, Tom Lane <[email-masked]> wrote:
> 

Oh, I thought at a checkpoint it would keep around some minimum, wal_keep_size, or wal_min_size. But I suppose I could set those to 0 if needed. Anyway, this would be a database solely for the purpose of running these tests, starting empty, so risk is not a factor unless I keep corrupting it between test stages ;-)