Subject: PostgreSQL Repos and archiving

From: Gabriel Guillem Barceló Soteras<[email-masked]>
Date: Tue, 12 May 2026 06:24:46 +0000

Hello,

I’m looking for guidance on how others are handling PGDG YUM repository maintenance on RHEL-like systems.

In our environment, we installed PostgreSQL 15 client libraries (postgresql15, libpq, etc.) across several hosts at a time when PostgreSQL 13 was still supported. As a result, the pgdg-redhat-all.repo file enabled multiple repositories (including pgdg13).

Now that PostgreSQL 13 has reached end-of-life, its repository has been moved to the archive, and the original URL no longer works. Because the repository remains enabled, dnf update fails when refreshing metadata. DNF skip_if_unavailabledoes not work because of the error code returned by the old repo (410?)

How are handling this situation apart from deleting old repo?

Gabriel B.

---

From: Laurenz Albe <[email-masked]>
Date: Tue, 12 May 2026 09:41:21 +0200

On Tue, 2026-05-12 at 06:24 +0000, Gabriel Guillem Barceló Soteras wrote:
> In our environment, we installed PostgreSQL 15 client libraries (postgresql15,libpq, etc.) across several
> hosts at a time when PostgreSQL 13 was still supported. As a result, thepgdg-redhat-all.repo file enabled
> multiple repositories (includingpgdg13).
> 
> Now that PostgreSQL 13 has reached end-of-life, its repository has been moved to the archive, and the
> original URL no longer works. Because the repository remains enabled, dnf update fails when refreshing
> metadata. DNF skip_if_unavailabledoes not work because of the error code returned by the old repo (410?)
> 

The proper way of dealing with that is to keep the package pgdg-redhat-repo updated.
Then the reference to the repositories of versions that are no longer supported will
vanish automatically, and you won't encounter the problem.

At the same time, keep updating your installations to the latest minor release.
That way, you can be certain to have the latest minor release for v13 when it goes
out of support.

Needless to say, you should upgrade way before a version goes out of support.

Yours,
Laurenz Albe