Subject: Error while starting EFM

From: Mahendra Singh <[email-masked]>
Date: Tue, 27 Aug 2024 19:55:08 +0400

Dear Experts,

I am unable to start EFM due to the below error.

*edb-efm-4.9.service: Control process exited, code=exited, status=1/FAILURE*

*edb-efm-4.9.service: Failed with result 'exit-code'.*
*Failed to start EnterpriseDB Failover Manager 4.9.*

Below is the startup log.

*Could not validate pg_wal directory:sudo -u enterprisedb
/usr/edb/efm-4.9/bin/efm_db_functions validatepgwaldir
/etc/edb/efm-4.9/efm.propertiesid: 3exit status: 1output:ERROR: Could not
read value of db.data.dir from /etc/edb/efm-4.9/efm.propertieserror:grep:
/etc/edb/efm-4.9/efm.properties: Permission deniedUsing ssl mode: disable*

It looks like much of the documentation for EFM errors are not available on
google.

Regards,
Mahendra Singh

---

From: Joe Conway <[email-masked]>
Date: Tue, 27 Aug 2024 11:58:45 -0400

On 8/27/24 11:55, Mahendra Singh wrote:
> *Could not validate pg_wal directory:
> sudo -u enterprisedb /usr/edb/efm-4.9/bin/efm_db_functions 
> validatepgwaldir /etc/edb/efm-4.9/efm.properties
> id: 3
> exit status: 1
> output:
> ERROR: Could not read value of db.data.dir from /etc/edb/efm-4.9/ 
> efm.properties
> error:
> grep: /etc/edb/efm-4.9/efm.properties: Permission denied
> Using ssl mode: disable*
> 
> It looks like much of the documentation for EFM errors are not 
> available on google.
> 
> Regards,
> Mahendra Singh

Please contact EDB support. This is not the appropriate place for help 
on that.

-- 
Joe Conway
PostgreSQL Contributors Team
RDS Open Source Databases
Amazon Web Services: https://aws.amazon.com

---

From: manish yadav <[email-masked]>
Date: Tue, 27 Aug 2024 16:30:05 +0000 (UTC)

There seems permission issue with efm.properties and efm.nodes files, these files need to have access from enterprisedb user if using EDB Postgres.

Thanks and Regards,

Manish Yadav

On Tuesday, 27 August 2024, 09:23:15 PM IST, Mahendra Singh <[email-masked]> wrote: 

Dear Experts,

edb-efm-4.9.service: Control process exited, code=exited, status=1/FAILURE
edb-efm-4.9.service: Failed with result 'exit-code'.
Failed to start EnterpriseDB Failover Manager 4.9.

Below is the startup log.
Could not validate pg_wal directory:
sudo -u enterprisedb /usr/edb/efm-4.9/bin/efm_db_functions validatepgwaldir /etc/edb/efm-4.9/efm.properties
id: 3
exit status: 1
output:
ERROR: Could not read value of db.data.dir from /etc/edb/efm-4.9/efm.properties
error:
grep: /etc/edb/efm-4.9/efm.properties: Permission denied
Using ssl mode: disable

It looks like much of the documentation for EFM errors are not available on google. 

Regards,
Mahendra Singh

---

From: postbox giridhar <[email-masked]>
Date: Wed, 28 Aug 2024 16:54:24 +0530

Also verify if the data directory mentioned in efm properties file is
correct or not and check the permissions of that file.
*ERROR: Could not read value of db.data.dir from
/etc/edb/efm-4.9/efm.properties*

---

From: Mahendra Singh <[email-masked]>
Date: Wed, 28 Aug 2024 15:28:20 +0400

Permissions are there and everything is correct
Still the same error
Works fine on standby node and witness node