Subject: Postgresql backup problem

From: Domen Šetar <[email-masked]>
Date: Fri, 30 Aug 2024 08:12:56 +0000

Hi admins,

I have specific problem with my postgresql 16 backup. Postgresql FSbased full backup is working, but incremental backup hangs indefinitely.
I'm using Commvault for backup and my postgresql archive directory is NFS share from TrueNAS.
I'm trying to solve the problem with Commvault guys, but the issue is that there is no error message in Commvault logs even debugging mode is at highest level.
Backup works normaly if I use NFS share from Linux NFS server.

I'm interested if anyone has similar configuration (Commvault + TrueNAS) that works?

Best regards!
[izum]

Domen Šetar
Computer Systems Support
IZUM - Institute of Information Science | Prešernova ulica 17 | 2000 Maribor | Slovenia
T: +386 2 25 20 339 | M: +386 41 676 342 | www.izum.si<http://www.izum.si/> | [email-masked]<mailto:[email-masked]>

---

From: vrms <[email-masked]>
Date: Mon, 9 Sep 2024 21:28:26 +0200

I guess it wouldn't hurt if you specify what exactly "Postgresql FSbased 
full backup" means.
Which tool are you using, what is your process, ... ?

On 8/30/24 10:12 AM, Domen Šetar wrote:
>
> Hi admins,
>
> I have specific problem with my postgresql 16 backup. Postgresql 
> FSbased full backup is working, but incremental backup hangs indefinitely.
>
> I’m using Commvault for backup and my postgresql archive directory is 
> NFS share from TrueNAS.
>
> I’m trying to solve the problem with Commvault guys, but the issue is 
> that there is no error message in Commvault logs even debugging mode 
> is at highest level.
>
> I’m interested if anyone has similar configuration (Commvault + 
> TrueNAS) that works?
>
> Best regards!
>
>
> 	
>
> Domen Šetar
> /Computer Systems Support/
> IZUM – Institute of Information Science| Prešernova ulica 17 | 2000 
> Maribor |Slovenia/
> /T: +386 2 25 20 339| M: +386 41 676 342| www.izum.si 
> <http://www.izum.si/>[email-masked] <mailto:[email-masked]>
>

---

From: Ron Johnson <[email-masked]>
Date: Mon, 9 Sep 2024 15:30:28 -0400

Sounds like he's using rsync.

On Mon, Sep 9, 2024 at 3:25 PM vrms <[email-masked]> wrote:

> I have specific problem with my postgresql 16 backup. Postgresql FSbased
> full backup is working, but incremental backup hangs indefinitely.
>
> I’m using Commvault for backup and my postgresql archive directory is NFS
> share from TrueNAS.
>
> I’m trying to solve the problem with Commvault guys, but the issue is that
> there is no error message in Commvault logs even debugging mode is at
> highest level.
>
> I’m interested if anyone has similar configuration (Commvault + TrueNAS)
> that works?
>
>
>
> Best regards!
>
>
> Domen Šetar
> *Computer Systems Support*
> IZUM – Institute of Information Science | Prešernova ulica 17 | 2000
> Maribor | Slovenia
> T: +386 2 25 20 339 | M: +386 41 676 342 | www.izum.si |
> [email-masked]
>
>
>
>
>
>

-- 
Death to America, and butter sauce.
Iraq lobster!