Subject: pg_upgrade utility with --link option

From: "M.Yousaf Maqsood" <[email-masked]>
Date: Sun, 15 Dec 2024 18:16:05 +0500

Hi Team,

I hope you are doing well.  Have anyone of you tried pg_upgrade with --link
option .

I was trying to upgrade from 15.3 to 17.1 . I successfully upgraded but my
new PGDATA is very small size and still referencing the old PGDATA dir
because it has used --link option.

Can anyone guide me on how to remove the previous PGDATA and fully rely on
the new PGDATA..

Kind Regards,

Muhammad Yousaf Maqsood

cell# +923134039397

https://www.linkedin.com/in/muhammadyousafmaqsood/

---

From: daur exp <[email-masked]>
Date: Wed, 18 Dec 2024 15:18:05 +0500

Hello, may be u need just edit .bash_profile file and put correct PGDATA
path?

ср, 18 дек. 2024 г. в 14:58, M.Yousaf Maqsood <[email-masked]>:

> Hi Team,
>
> I hope you are doing well.  Have anyone of you tried pg_upgrade with
> --link option .
>

---

From: Scott Ribe <[email-masked]>
Date: Wed, 18 Dec 2024 06:15:54 -0700

Those are hard links. If you're successfully running PG 17 against the new dir, just delete the old one.

https://linuxhandbook.com/hard-link/

--
Scott Ribe
[email-masked]
https://www.linkedin.com/in/scottribe/

> On Dec 15, 2024, at 6:16 AM, M.Yousaf Maqsood <[email-masked]> wrote:
> 
> Can anyone guide me on how to remove the previous PGDATA and fully rely on the new PGDATA..
>