Subject: Postgres Extensions

From: Sam Stearns <[email-masked]>
Date: Mon, 30 Sep 2024 16:30:46 -0700

Howdy,

Is there an easy way to install all extensions available to Postgres in one
hit?

Thanks,

Sam

-- 

*Samuel Stearns*
Lead Database Administrator
*c:* 971 762 6879 | *o:* 503 672 5115 | DAT.com
<https://www.dat.com/?utm_medium=email&utm_source=DAT_email_signature_link>

---

From: Kashif Zeeshan <[email-masked]>
Date: Tue, 1 Oct 2024 10:26:49 +0500

Hi

There is no single command that install all available extensions.

Regards
Kashif Zeesgan

On Tue, Oct 1, 2024 at 4:31 AM Sam Stearns <[email-masked]> wrote:

> Howdy,
>
> Is there an easy way to install all extensions available to Postgres in
> one hit?
>
> Thanks,
>
> Sam
>
> --
>
> *Samuel Stearns*

---

From: Wells Oliver <[email-masked]>
Date: Mon, 30 Sep 2024 22:28:09 -0700

What in the world is the use case here, sounds like madness.

-- 
Wells Oliver
[email-masked] <[email-masked]>

---

From: khan Affan <[email-masked]>
Date: Tue, 1 Oct 2024 10:34:08 +0500

Hello

You can automate Postgresql-contrib with a script to install all extensions
or from the pg_available_extensions table. Other than that, as far as I
know, no single command can do it at once.

Thanks

*Muhammad Affan (*아판*)*

*PostgreSQL Technical Support Engineer** / R&D*

---

From: Dan Smith <[email-masked]>
Date: Tue, 1 Oct 2024 09:23:52 -0400

Think you might want to look at https://pigsty.io/

Best regards,

Dan Smith

---

From: Sam Stearns <[email-masked]>
Date: Tue, 1 Oct 2024 08:02:40 -0700

Thank you everyone.  I think I'll just install the 2 that I need for now.

Sam

-- 

*Samuel Stearns*