Subject: I'm trying to update postgres from 15.5 to 15.8. Got this error.

From: Pär Mattsson <[email-masked]>
Date: Wed, 11 Sep 2024 07:13:20 +0000

[root@localhost]# yum update postgresql
Updating Subscription Management repositories.
PostgreSQL common RPMs for RHEL / Rocky 8 - x86_64                                                                                                                     2.0 kB/s | 659  B     00:00
PostgreSQL common RPMs for RHEL / Rocky 8 - x86_64                                                                                                                     1.6 MB/s | 1.7 kB     00:00
PostgreSQL common RPMs for RHEL / Rocky 8 - x86_64                                                                                                                     1.0 kB/s | 659  B     00:00
Error: Failed to download metadata for repo 'pgdg-common': repomd.xml GPG signature verification error: Bad GPG signature

[root@vidi-db02 ~]# dnf list installed | grep postgres
postgresql15.x86_64                           15.5-1PGDG.rhel8                          @pgdg15
postgresql15-libs.x86_64                      15.5-1PGDG.rhel8                          @pgdg15
postgresql15-server.x86_64                    15.5-1PGDG.rhel8                          @pgdg15

Br Pär Mattsson

Kind regards,

Pär Mattsson
Database specialist
M +46706069645
E [email-masked]

Cegal Sverige AB

---

From: Pär Mattsson <[email-masked]>
Date: Wed, 11 Sep 2024 07:18:28 +0000

Från: Pär Mattsson
Skickat: den 11 september 2024 09:13
Till: Pgsql-admin <[email-masked]>
Ämne: I'm trying to update postgres from 15.5 to 15.8. Got this error.

Br Pär Mattsson

---

From: Asad Ali <[email-masked]>
Date: Wed, 11 Sep 2024 13:04:06 +0500

Hi  Pär Mattsson,

The error message indicates a problem with the GPG signature verification
for the repository metadata, which is preventing the yum or dnf package
manager from updating PostgreSQL.

Run the following commands to clear the DNF cache and rebuild it:
sudo dnf clean all
sudo dnf makecache

The GPG signature verification error could be caused by a missing or
corrupted GPG key for the PostgreSQL repository. You can manually download
and install the key.
sudo rpm --import
https://download.postgresql.org/pub/repos/yum/RPM-GPG-KEY-PGDG

Verify the key has been installed.
rpm -qi gpg-pubkey | grep -i "PostgreSQL"

After ensuring the GPG key is correctly installed, try updating PostgreSQL
again.
sudo yum update postgresql*
or
sudo dnf update postgresql*

Best Regards,
Asad Ali

On Wed, Sep 11, 2024 at 12:18 PM Pär Mattsson <[email-masked]>
wrote:

>
>
>
> *Från:* Pär Mattsson
> *Skickat:* den 11 september 2024 09:13
> *Till:* Pgsql-admin <[email-masked]>
> *Ämne:* I'm trying to update postgres from 15.5 to 15.8. Got this error.
>
>
>
> PostgreSQL common RPMs for RHEL / Rocky 8 -
> x86_64
> 2.0 kB/s | 659  B     00:00
>
> PostgreSQL common RPMs for RHEL / Rocky 8 -
> x86_64
> 1.6 MB/s | 1.7 kB     00:00
>
> PostgreSQL common RPMs for RHEL / Rocky 8 -
> x86_64
> 1.0 kB/s | 659  B     00:00
>
> *Error: Failed to download metadata for repo 'pgdg-common': repomd.xml GPG
> signature verification error: Bad GPG signature*
>
>
>
>
>