Subject: Psql not working

From: "Narendran .j" <[email-masked]>
Date: Thu, 12 Dec 2024 19:01:28 +0530

Hello Team,

I'm facing one problem, can't login postgres by psql, even it's not
throwing any error and can't find anything in log.

Checked server is running fine, able to check status using pg_ctl. Can
can't login through psql

My login attempt

psql
/usr/pgsql-14/bin/psql
psql -U postgres -p 5432 -d postgres

When I'm running above query it's return to next line, nothing comes up

Please on this.

Thanks

---

From: "Dischner, Anton" <[email-masked]>
Date: Thu, 12 Dec 2024 13:36:54 +0000

Hi,

which user are you?
Check with: id

Try something like "su - postgres" before issuing psql command

Best,

Anton

Von: Narendran .j <[email-masked]>
Gesendet: Donnerstag, 12. Dezember 2024 14:31
An: [email-masked]
Betreff: Psql not working

Hello Team,

I'm facing one problem, can't login postgres by psql, even it's not throwing any error and can't find anything in log.

Checked server is running fine, able to check status using pg_ctl. Can can't login through psql

My login attempt

psql
/usr/pgsql-14/bin/psql

Please on this.

Thanks

---

From: Kashif Zeeshan <[email-masked]>
Date: Thu, 12 Dec 2024 19:10:33 +0500

Hi

Can you check which user you are using to run psql,

Do the following
1. Execute ls -lrt /usr/pgsql../bin/psql to see if the user have access to
it

2. If you have access then try running the command psql --help to make sure
if you have access to psql.

3. Also try to connect with the wrong user / port to see if psql generates
error.

Regards
Kashif Zeeshan

---

From: "Narendran .j" <[email-masked]>
Date: Thu, 12 Dec 2024 20:14:36 +0530

I have checked the user, user is postgres
I have noted that in bin path the size of psql client is 0
psql --version and psql --help not working
so i suspecting the psql client

Regards,
Narendran

On Thu, 12 Dec 2024 at 19:40, Kashif Zeeshan <[email-masked]>
wrote:

> 2. If you have access then try running the command psql --help to make
> sure if you have access to psql.
>

---

From: Kashif Zeeshan <[email-masked]>
Date: Thu, 12 Dec 2024 19:57:43 +0500

> so i suspecting the psql client

It means the psql is not properly installed. Try to re-install postgres
client again.

>> 1. Execute ls -lrt /usr/pgsql../bin/psql to see if the user have access
>> to it
>>
>> 3. Also try to connect with the wrong user / port to see if psql
>> generates error.
>>
>> Regards
>> Kashif Zeeshan
>>

---

From: Holger Jakobs <[email-masked]>
Date: Thu, 12 Dec 2024 15:58:34 +0100

> so i suspecting the psql client

Try finding psql on your disk with

   find / -xdev -name psql -ls

and check whether one of the files found is an executable with

   file path_of_file

and try it if it is.

Maybe your original psql file was deleted or its length set to zero by 
incident. You might as well re-install your client package in order to 
repair it.

Regards,
Holger

-- 

Holger Jakobs, Bergisch Gladbach

---

From: Rajesh Kumar <[email-masked]>
Date: Thu, 12 Dec 2024 20:32:43 +0530

I don't think the size 0 is a problem here.

---

From: vignesh kumar <[email-masked]>
Date: Thu, 12 Dec 2024 15:05:08 +0000

Re install your client binaries.. could be one potential problem..

Sent from Outlook for Android<https://aka.ms/AAb9ysg>
________________________________
From: Narendran .j <[email-masked]>
Sent: Thursday, December 12, 2024 7:01:28 PM
To: [email-masked] <[email-masked]>
Subject: Psql not working

Hello Team,

My login attempt

psql
/usr/pgsql-14/bin/psql

Please on this.

Thanks

---

From: "Dischner, Anton" <[email-masked]>
Date: Thu, 12 Dec 2024 15:05:57 +0000

Hi,

on my system ist:

which psql
/usr/bin/psql
postgres@myserver:~$ file /usr/bin/psql
/usr/bin/psql: symbolic link to ../share/postgresql-common/pg_wrapper
file /usr/share/postgresql-common/pg_wrapper
/usr/share/postgresql-common/pg_wrapper: Perl script text executable

Regards,

Anton

Von: Rajesh Kumar <[email-masked]>
Gesendet: Donnerstag, 12. Dezember 2024 16:03
An: Holger Jakobs <[email-masked]>
Cc: [email-masked]
Betreff: Re: Psql not working

On Thu, 12 Dec 2024, 20:28 Holger Jakobs, <[email-masked]<mailto:[email-masked]>> wrote:

   file path_of_file

and try it if it is.

Regards,
Holger

--