Subject: Postgres capacity planning.

From: Daulat <[email-masked]>
Date: Wed, 23 Oct 2024 17:32:15 +0530

Hello Everyone.

Could anyone please suggest any freeware tools, scripts, or ideas for
creating a capacity planning solution for a PostgreSQL database? Thank you.

---

From: Alex Balashov <[email-masked]>
Date: Wed, 23 Oct 2024 08:13:35 -0400

> On Oct 23, 2024, at 8:02 am, Daulat <[email-masked]> wrote:
> 
> Could anyone please suggest any freeware tools, scripts, or ideas for creating a capacity planning solution for a PostgreSQL database? Thank you.

I suppose this is one of those areas where "knowing Postgres well" is the idea, and it's unlikely that this can be replaced with a tool.

-- 
Alex Balashov
Principal Consultant
Evariste Systems LLC
Web: https://evaristesys.com
Tel: +1-706-510-6800

---

From: SOzcn <[email-masked]>
Date: Wed, 23 Oct 2024 15:35:42 +0300

I don't sure what you asking for but there is no any tool enough for the
progresses. If you look some enterprise thing you can check pganalyze.
PostgreSQL have enough monitoring extensions anyway. One of them is
pgbadger, you can look at it.

Have a nice day.

Alex Balashov <[email-masked]>, 23 Eki 2024 Çar, 15:13 tarihinde
şunu yazdı:

> I suppose this is one of those areas where "knowing Postgres well" is the
> idea, and it's unlikely that this can be replaced with a tool.
>
> --
> Alex Balashov
> Principal Consultant
> Evariste Systems LLC

---

From: Muhammad Usman Khan <[email-masked]>
Date: Thu, 24 Oct 2024 08:17:24 +0500

Hi,

For PostgreSQL capacity planning, you can explore several freeware tools
and approaches that help monitor and forecast database resource
utilization. Some of the approaches are as follows:
* pgmetrics: A tool used to collects and reports PostgreSQL metrics such as
database size, table sizes, buffer cache utilization, index usage etc
* pg_stat_statements: Tracks execution statistics for all SQL queries
* pgCluu: It provides detailed reports and charts based on system
statistics and PostgreSQL performance.
* you can use the combination of Prometheus and Grafana
* Pgbadger: It generates performance reports based on log files.

---

From: Claus Koch <[email-masked]>
Date: Thu, 24 Oct 2024 19:13:33 +0200

> creating a capacity planning solution for a PostgreSQL database? Thank you.

When I was confronted with capacity planning a few years ago, I found this book
helpful. I was in a situation in which I was confronted with high expectations
and little or inaccurate specification at the same time. A situation that many
here are sure to recognise.

  Guerilla Capacity Planning 
  by Neil J. Gunther
  Springer 2007

Cheers

-- 
  \
   Claus Koch <[email-masked]>
    Wilhelmshavener Str. 56, 10551 Berlin, Germany, +49 30 3951607