Subject: Regexp_replace help

From: Chris Hoover <[email-masked]>
Date: Thu, 12 Sep 2024 17:18:30 -0400

Looking for some help here.  I have a string that has ‘code1234’ in it.  The 1234 can vary and I won’t know what they would be.  Trying to figure out how to use regexp_replace to trim down the string, but unsure how to keep the ‘code1234’ in the string.

The search should be ‘ code[0-9]+? .*’. However, I don’t understand what the replace should be.

I.E.:
SELECT regexp_replace(’This is my test string that caused code12 from abc’,
                                         ‘ code[0-9]+? .*’,
                                         ‘What should this be so I keep the code12?‘)
Desire result:
’This is my test string that caused code12’

SELECT regexp_replace(’This is my second test string and it is causing code1234 from def.  The weather is nice. :)’,
                                         ‘ code[0-9]+? .*’,
                                         ‘What should this be so I keep the code1234?’)
Desire result:
‘This is my second test string and it is causing code1234’

Thanks,

Chris Hoover
Senior DBA
AWeber.com
Cell: (803) 528-2269
Email: [email-masked]

---

From: "David G. Johnston" <[email-masked]>
Date: Thu, 12 Sep 2024 14:22:54 -0700

On Thursday, September 12, 2024, Chris Hoover <[email-masked]> wrote:

>
> SELECT regexp_replace(’This is my second test string and it is causing
> code1234 from def.  The weather is nice. :)’,
>                                          ‘ code[0-9]+? .*’,

Probably easier to just regexp_match “^(.+?code\d+)\b”, and keep the
contents of group 1.

David J.

---

From: jian he <[email-masked]>
Date: Fri, 13 Sep 2024 09:14:51 +0800

> ‘This is my second test string and it is causing code1234’

please try these.

select SUBSTRING($$This is my test string that caused code12 from
abc$$ from '.*(?:code[0-9]\S+)');
select SUBSTRING($$This is my test string that caused code12s1 from
abc$$ from '.*(?:code\S+)');
SELECT SUBSTRING($$This is my second test string and it is causing
code1234 from def.  The weather is nice. :$$
from '.*(?:code\S+)');