Subject: Info regarding pg upgrade from 12.18 to 15.6

From: Motog Plus <[email-masked]>
Date: Fri, 27 Sep 2024 16:55:21 +0530

Hi Team,

We are upgrading postgres from 12.18 to 15.6. Can you please advise how can
I check on the below points?
1. Compatibility between postgreSQL 15.6 and:
     - Springboot(3.3..x)
     - Java(17)
     - JPA
     - Hikari pool
     - pgpool II

Thanks in advance.

Regards,
Raman

---

From: Laurenz Albe <[email-masked]>
Date: Fri, 27 Sep 2024 14:38:36 +0200

On Fri, 2024-09-27 at 16:55 +0530, Motog Plus wrote:
> We are upgrading postgres from 12.18 to 15.6. Can you please advise how can I check on the below points?

Check the documentation of these programs to see if they support PostgreSQL v15.

But the most important part is that you test your applications thoroughly.
Even if all the software on your stack supports PostgreSQL v15, it is
conceivable that your program does something with the database that changed
in an incompatible fashion.

It is instructive to read the "migration" section of the release notes
for the PostgreSQL major releases, but there is no way for you to avoid
testing your program.

Yours,
Laurenz Albe