Subject: Hide psql passwords

From: Mauricio Fernandez <[email-masked]>
Date: Tue, 18 Nov 2025 10:33:57 -0300

Hi admins, I'm wondering if there is any other way the password in a psql
session besides .pgpass file??

Some thing like oracle wallets ??

Thanks in advance

regards

Mauricio Fernández

---

From: "David G. Johnston" <[email-masked]>
Date: Tue, 18 Nov 2025 07:51:25 -0600

> session besides .pgpass file??

That, or an environment variable.

David J.

---

From: Mauricio Fernandez <[email-masked]>
Date: Tue, 18 Nov 2025 10:58:56 -0300

Thank you for answering my questions David

kind regards

MF

---

From: Ron Johnson <[email-masked]>
Date: Tue, 18 Nov 2025 09:27:26 -0500

> Some thing like oracle wallets ??

There's GSSAPI encryption, if you have Active Directory.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Mauricio Fernandez <[email-masked]>
Date: Tue, 18 Nov 2025 11:44:40 -0300

Thanks for the tip Ron

Kind regards

Mauricio Fernández