Subject: Direct particular index use as like oracle

From: Sathish Reddy <[email-masked]>
Date: Fri, 11 Oct 2024 16:28:40 +0530

Hi
  We see direct use particular index in oracle.same we are trying to use in
postgres.but every time we ae getting failed.please help us.

Thanks
Sathish Reddy

---

From: Avinash Vallarapu <[email-masked]>
Date: Fri, 11 Oct 2024 16:20:12 +0400

Hi,

On Fri, Oct 11, 2024, 2:59 PM Sathish Reddy <
[email-masked]> wrote:

> Hi
>   We see direct use particular index in oracle.same we are trying to use
> in postgres.but every time we ae getting failed.please help us.
>
Do you mean that you don't see an Index being considered by planner in
Postgres, whereas a similar index is used in Oracle ?

If the above is yes, can you provide some more information?

> Sathish Reddy

Regards,
Avi.

Try HexaRocket today for your Oracle to PostgreSQL Migrations.

www.hexarocket.com

---

From: Sathish Reddy <[email-masked]>
Date: Fri, 11 Oct 2024 17:54:45 +0530

Yes, that is correct.

---

From: Avinash Vallarapu <[email-masked]>
Date: Fri, 11 Oct 2024 16:35:44 +0400

Hi,

> Yes, that is correct.
Okay. You might have to provide some more information to get more help such
as, the SQL, it's Query Plan and Table DDL.

If you have migrated this table from Oracle, you might have to perform a
Vacuum Analyze on this table before you try anything.

Vacuum analyze <table>;

---

From: Keith <[email-masked]>
Date: Fri, 11 Oct 2024 08:36:57 -0400

> in postgres.but every time we ae getting failed.please help us.

There are no query hints in Postgres to direct it to use a particular
index. Often it's the query itself that can be tuned to fix this happening
or the ideal plan is actually being used vs the index you think you expect
it should use.

Share the query plan and table structure and people might be able to help
you out more.

---

From: vignesh kumar <[email-masked]>
Date: Tue, 15 Oct 2024 16:04:19 +0000

When you say failed what does it say?

Sent from Outlook for Android<https://aka.ms/AAb9ysg>
________________________________
From: Keith <[email-masked]>
Sent: Friday, October 11, 2024 6:06:57 PM
To: Sathish Reddy <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: Direct particular index use as like oracle

On Fri, Oct 11, 2024 at 6:59 AM Sathish Reddy <[email-masked]<mailto:[email-masked]>> wrote:
Hi
  We see direct use particular index in oracle.same we are trying to use in postgres.but every time we ae getting failed.please help us.

Thanks
Sathish Reddy

There are no query hints in Postgres to direct it to use a particular index. Often it's the query itself that can be tuned to fix this happening or the ideal plan is actually being used vs the index you think you expect it should use.

Share the query plan and table structure and people might be able to help you out more.