Subject: Postgres exporter v0.140 Connection Leak Issue

From: kamal deen <[email-masked]>
Date: Mon, 30 Dec 2024 22:23:34 +0530

Hi All,

We have observed sudden connection spikes in some of our prod instances due
to idle session which was created by postgres exporters.

We have fixed this  post restarted the postgres exporter services.

Kindly share if we have any bug fixes for the same.

Thanks in advance.

SK

---

From: Ron Johnson <[email-masked]>
Date: Mon, 30 Dec 2024 12:44:01 -0500

On Mon, Dec 30, 2024 at 11:53 AM kamal deen <[email-masked]> wrote:

> Hi All,
>
> We have observed sudden connection spikes in some of our prod instances
>

Define "sudden".

> due to idle session which was created by postgres exporters.
>

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: kamal deen <[email-masked]>
Date: Mon, 30 Dec 2024 23:26:14 +0530

Hi John,

Example.

Out of 200 max connections , 160 idle connections consumed by postgres
exporter suddenly during non peak hours. There's is no specific time
pattern.

Please let me know if need any other details.

SK

---

From: Ron Johnson <[email-masked]>
Date: Mon, 30 Dec 2024 13:00:33 -0500

Have these spikes *suddenly started happening*, after months/years of not
having lots of idle connections?
OR
Have you seen *sudden spikes* in the number of idle connections for as long
as you've been running Postgres Exporter v0.14.0?

---

From: kamal deen <[email-masked]>
Date: Mon, 30 Dec 2024 23:33:50 +0530

We have seen *sudden spikes* in the number of idle connections after
installed Postgres Exporter v0.14.0.

On Mon, Dec 30, 2024, 11:30 PM Ron Johnson <[email-masked]> wrote:

> Have you seen *sudden spikes* in the number of idle connections for as
> long as you've been running Postgres Exporter v0.14.0?
>

---

From: Ron Johnson <[email-masked]>
Date: Mon, 30 Dec 2024 13:14:22 -0500

Is this the project, or some other postgres exporter?
https://github.com/prometheus-community/postgres_exporter

On Mon, Dec 30, 2024 at 1:04 PM kamal deen <[email-masked]> wrote:

>> Have these spikes *suddenly started happening*, after months/years of
>> not having lots of idle connections?
>> OR

---

From: kamal deen <[email-masked]>
Date: Tue, 31 Dec 2024 00:26:25 +0530

Yes , this is the one but we have installed v0.14.0

---

From: Ron Johnson <[email-masked]>
Date: Mon, 30 Dec 2024 14:57:48 -0500

Have you tried reading the release notes for later releases?
Have you tried opening an issue on GitHub?