Subject: pg_dump -j

From: Sam Stearns <[email-masked]>
Date: Wed, 12 Nov 2025 07:33:48 -0800

Howdy,

Would someone be able to advise on the correct setting for the -j option of
pg_dump to run the dump in parallel, please?  Is it based on CPU count, or
something else?  The output of nproc is 32.

Thank you,

Sam

-- 

Samuel Stearns
Team Lead - Database
c: 971 762 6879 | o: 971 762 6879 | DAT.com

<https://www.dat.com/?utm_medium=email&utm_source=DAT_email_signature_link>

---

From: Ron Johnson <[email-masked]>
Date: Wed, 12 Nov 2025 11:11:56 -0500

On Wed, Nov 12, 2025 at 10:34 AM Sam Stearns <[email-masked]> wrote:

> Howdy,
>
> Would someone be able to advise on the correct setting for the -j option
> of pg_dump to run the dump in parallel, please?  Is it based on CPU count,
> or something else?  The output of nproc is 32.
>

I'd certainly never go *beyond* $(nproc), but since COPY generates a lot of
IO and compression burns through CPU, it all depends on the system's other
workload.  Only you know what your system's other workload is when pg_dump
is running.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: CONVERS Yann - DREAL Auvergne-Rhône-Alpes/CIDDAE/SIG<[email-masked]>
Date: Thu, 13 Nov 2025 09:28:15 +0100

Hi,

Processeurs is on of the parameters . An other is the
outpout:input capacity to write on disks.

I purpose to test your hardware performance with 12 jobs to begin
and test less and high to learn which is better.

You can found it approximately with the rate of your speeding
writing ratio on disk or outpout of LAN card factoring by job's
number.

But testing IRL is more efficient.

We use 7 jobs for à 16 nprocs on saving on a master save dedicate
to with car LAN 1000GhZ for example.

We do it online but without clients traffic and without
maintenance operation.

Tell us wich is your better choice!

Bye

Yann

Le 12/11/2025 à 17:11, >
ronljohnsonjr (par Internet, dépôt
[email-masked]) a écrit :

On Wed, Nov 12, 2025 at 10:34 AM Sam Stearns <[email-masked]>
wrote:

Howdy,

Would someone be able to advise on the correct
setting for the -j option of pg_dump to run the dump in
parallel, please?  Is it based on CPU count, or
something else?  The output of nproc is 32.

I'd certainly never go beyond $(nproc), but since
COPY generates a lot of IO and compression burns through CPU,
it all depends on the system's other workload.  Only you know
what your system's other workload is when pg_dump is running.

--

<Redacted> lobster!

---

From: Sam Stearns <[email-masked]>
Date: Thu, 13 Nov 2025 07:12:17 -0800

Thanks, Yann!

On Thu, Nov 13, 2025 at 3:40 AM CONVERS Yann - DREAL
Auvergne-Rhône-Alpes/CIDDAE/SIG <[email-masked]>
wrote:

> Hi, Processeurs is on of the parameters . An other is the outpout: input
> capacity to write on disks. I purpose to test your hardware performance
> with 12 jobs to begin and test less and high to learn which is better. You
> can found it approximately
> ZjQcmQRYFpfptBannerStart
> This Message Is From an Untrusted Sender
> You have not previously corresponded with this sender.
>
> ZjQcmQRYFpfptBannerEnd
>
> Hi,
>
> Processeurs is on of the parameters . An other is the outpout:input
> capacity to write on disks.
>
> I purpose to test your hardware performance with 12 jobs to begin and test
> less and high to learn which is better.
>
> You can found it approximately with the rate of your speeding writing
> ratio on disk or outpout of LAN card factoring by job's number.
>
> We use 7 jobs for à 16 nprocs on saving on a master save dedicate to with
> car LAN 1000GhZ for example.
>
> We do it online but without clients traffic and without maintenance
> operation.
>
> Le 12/11/2025 à 17:11, > ronljohnsonjr (par Internet, dépôt
> I'd certainly never go *beyond* $(nproc), but since COPY generates a lot
> of IO and compression burns through CPU, it all depends on the system's
> other workload.  Only you know what your system's other workload is when
> pg_dump is running.
>
> --

-- 

Samuel Stearns
Team Lead - Database