Subject: using pgbackrest in a PG streaming replication cfg with repmgr

From: "Ghiurea, Isabella" <[email-masked]>
Date: Tue, 26 Aug 2025 17:44:51 +0000

Hi List,

We  have a requirement to start using pgbackrest for  db backups  on slave PG hosts already configured in Streaming Replication  .   To avoid any issues with WAL files  transfer and performance in  existing PG streaming replication configuration , we plan to run pgbackrest only at a slave host and only full database backups ( no need for PITR/incremental  when already have synchronous replication) . My questions are :

-How do I cfg pgbackrest to not archive/use WAL files  without affecting the synchronous  streaming replication?

- Are any known issues with pgbackrest + repmgr  when running : repmgr standby switchover  ?( to promote a new  db master while slave is online ) or repmgr promote ?

thank you !!!

---

From: Ron Johnson <[email-masked]>
Date: Tue, 26 Aug 2025 14:50:10 -0400

On Tue, Aug 26, 2025 at 1:45 PM Ghiurea, Isabella <
[email-masked]> wrote:

>  no need for PITR/incremental  when already have synchronous replication
>

What happens when you take backups on Sundays, today is Tuesday, but you
need the state of the database as it was on Monday at 09:00?

Remember: replication is not a backup!!

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Ron Johnson <[email-masked]>
Date: Tue, 26 Aug 2025 14:56:02 -0400

On Tue, Aug 26, 2025 at 1:45 PM Ghiurea, Isabella <
[email-masked]> wrote:

> and only full database backups
>

If you only want to do full backups, then use pg_dump on the replica
server.  Might need to adjust parameters like max_standby_streaming_delay
and hot_standby_feedbac, just like for long-running queries on the replica.

https://www.postgresql.org/docs/16/runtime-config-replication.html
<https://www.postgresql.org/docs/16/runtime-config-replication.html#GUC-MAX-STANDBY-STREAMING-DELAY>