Subject: Can't log in after password change

From: Ron Johnson <[email-masked]>
Date: Thu, 3 Oct 2024 13:21:43 -0400

PG 14.13

Changed a user's expired password from user "postgres", and now that user
can't log in.

I know it's something simple, but I just can't see it.

Linux server:

$ ssh -q FISPCDSPGS401A grep 11026270 '$PGDATA'/pg_hba.conf
host    all             11026270        10.176.64.0/22
 scram-sha-256

$ psql -h FISPCDSPGS401A
 keyword  |     value
----------+---------------
 database | postgres
 user     | postgres
 host     | 10.143.170.55
 port     | 5432
(4 rows)

psql (16.4, server 14.13)
Type "help" for help.

postgres=# ALTER ROLE "11026270" WITH PASSWORD 'blarge';
ALTER ROLE
postgres=# select rolpassword from pg_authid where rolname='11026270';
                                                              rolpassword

---------------------------------------------------------------------------------------------------------------------------------------
 SCRAM-SHA-256$4096:x551tt4biKIvossG7VwbjA==$syOJXKLOFZ8/LHUxHq8rE5q5dCEDNzB5wgOAHq1vmdI=:q670pqidak6v8YjP9KCCWrRmfkkJSvyf/AL0Ydg1k/o=
(1 row)

Windows server:

C:\Users\11026270>psql -h FISPCDSPGS401A postgres
Password for user 11026270:
psql: error: connection to server at "FISPCDSPGS401A" (10.143.170.55), port
5432 failed: FATAL:  password authentication failed for user "11026270"

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> crustacean!

---

From: Laurenz Albe <[email-masked]>
Date: Thu, 03 Oct 2024 19:34:09 +0200

On Thu, 2024-10-03 at 13:21 -0400, Ron Johnson wrote:
> PG 14.13
> 
> Changed a user's expired password from user "postgres", and now that user can't log in.
> 
> host    all             11026270        10.176.64.0/22              scram-sha-256
> 
> $ psql -h FISPCDSPGS401A 
>  keyword  |     value     
> psql: error: connection to server at "FISPCDSPGS401A" (10.143.170.55), port 5432 failed: FATAL:  password authentication failed for user "11026270"

Did you look at the error message in the server log?
What does it say?

Yours,
Laurenz Albe

---

From: Ron Johnson <[email-masked]>
Date: Thu, 3 Oct 2024 13:39:37 -0400

On Thu, Oct 3, 2024 at 1:34 PM Laurenz Albe <[email-masked]>
wrote:

> > psql: error: connection to server at "FISPCDSPGS401A" (10.143.170.55),
> port 5432 failed: FATAL:  password authentication failed for user "11026270"
>

Expired password.  I guess I assumed that the ALTER ROLE would nullify it.
And that psql would mention it.

---

From: Casey <[email-masked]>
Date: Thu, 3 Oct 2024 16:48:20 -0500

😂