Subject: Migration from CentOS7 to RedHat 9

From: Wasim Devale <[email-masked]>
Date: Sat, 10 Aug 2024 16:44:33 +0530

Hi All

I took dump via pg_dump doing ssh from Red hat it took almost 10 hours for
400GB data including 99GB of BLOBS large objects.

ssh postgres@ipaddre "pg_dump -U postgres -d DB1 F c -b -v" > /path/pg.dump

Is this normal?

Thanks,
Wasim

---

From: Ron Johnson <[email-masked]>
Date: Sat, 10 Aug 2024 09:05:19 -0400

> ssh postgres@ipaddre "pg_dump -U postgres -d DB1 F c -b -v" >

I see a typo.  Is this a copy/paste of what you ran?

Is this normal?

Maybe.  Blobs are slow.  I'd have done a multi-threaded pg_dump, though
blobs might be the bottleneck.

-- 
Death to America, and butter sauce.
Iraq lobster!

---

From: Wasim Devale <[email-masked]>
Date: Sat, 10 Aug 2024 18:55:53 +0530

Yes, I used the same command I changed the values for this email. And that
particular table with BLOBS took a longer time.

I am running a pg_restore now using -j 10 in the command. Please confirm,
what you anticipate, will it take same time for restoration on Red Hat 9?

Thanks,
Wasim

On Sat, 10 Aug, 2024, 6:35 pm Ron Johnson, <[email-masked]> wrote:

>> I took dump via pg_dump doing ssh from Red hat it took almost 10 hours
>> for 400GB data including 99GB of BLOBS large objects.
>>

---

From: Ron Johnson <[email-masked]>
Date: Sat, 10 Aug 2024 14:36:25 -0400

"RHEL9" has almost nothing to do with how fast it will restore.  It's all
about how fast your disk are, number of CPUs, postgresql.conf settings.

And, of course, blobs are slow.

---

From: Wasim Devale <[email-masked]>
Date: Sun, 11 Aug 2024 10:51:34 +0530

Thanks it took 3 hours to complete the restoration. The existing CentOS7
resources were limited as you rightly said about CPU and all. Thanks

On Sun, 11 Aug, 2024, 12:06 am Ron Johnson, <[email-masked]> wrote:

>> Yes, I used the same command I changed the values for this email. And
>> that particular table with BLOBS took a longer time.
>>

---

From: Muhammad Waqas <[email-masked]>
Date: Mon, 12 Aug 2024 10:47:08 +0500

what is the bandwidth between source and destination?

what is the memory of your source server?

-- 
*Muhammad Waqas*
*Senior Technical Support Engineer - Tech Support Center (Karachi)*
Mobile: +92-322-2844150
Email:  [email-masked] <[email-masked]>*
1st floor, suit no F-04, COLABS Karachi, 8-C Khayaban-e-Tanzeem,
DHA Phase 5 Tauheed Commercial Area,
Defense V Defense Housing Authority, Karachi, Karachi City, Sindh,
75500 Pakistan.