Subject: Upgrade for primary standby config

From: Siddhartha Jain <[email-masked]>
Date: Fri, 3 Jan 2025 06:21:34 +0530

Hello All,

Please provide me with the high level steps for upgrade in postgres from 11
to 15 version for primary-standby configuration setup.

Thanks,
Sid

---

From: Laurenz Albe <[email-masked]>
Date: Fri, 03 Jan 2025 09:21:27 +0100

On Fri, 2025-01-03 at 06:21 +0530, Siddhartha Jain wrote:
> Please provide me with the high level steps for upgrade in postgres from 11 to 15 version
> for primary-standby configuration setup.

You cannot use a streaming replication standby server; you have to use logical replication.

- set up a logical replication standby server
- wait until replication has caught up
- stop your application
- set the sequences on the subscriber (they are not replicated)
- drop the subscription
- make the application run with the new database

I recommend that you use pg_upgrade rather than logical replication.

Yours,
Laurenz Albe

---

From: Ron Johnson <[email-masked]>
Date: Fri, 3 Jan 2025 03:31:39 -0500

> You cannot use a streaming replication standby server; you have to use

Or does OP mean that he wants to upgrade both the primary and replica at
the same time?

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!