Subject: How do dump server wide configuration?

From: Ron Watkins <[email-masked]>
Date: Mon, 21 Oct 2024 11:22:07 -0700

I have been dumping individual databases with the pg_dump command, but a
issue has come up where user configs and other data stored at the server
level are not being dumped. Is there a way to dump those data as well?

-- 
Ron Watkins, K7DOG
602.743.5272

---

From: Joe Conway <[email-masked]>
Date: Mon, 21 Oct 2024 14:26:25 -0400

> level are not being dumped. Is there a way to dump those data as well?

perhaps:
   pg_dumpall -g

https://www.postgresql.org/docs/current/app-pg-dumpall.html

HTH,

-- 
Joe Conway
PostgreSQL Contributors Team
RDS Open Source Databases
Amazon Web Services: https://aws.amazon.com

---

From: Muhammad Usman Khan <[email-masked]>
Date: Tue, 22 Oct 2024 08:57:04 +0500

Hi,
You can use pg_dumpall. This will create a complete dump of all databases
along with the global objects.