Subject: No Message "PostgreSQL, contrib, and documentation successfully made. Ready to install."

From: "William Sescu (Suva)" <[email-masked]>
Date: Tue, 13 Aug 2024 08:07:04 +0000

Dear PG Admins

There used to be messages like the following after running make or make or make install-world, after the compilation of PostgreSQL.

-- "PostgreSQL, contrib, and documentation successfully made. Ready to install."

-- "PostgreSQL, contrib, and documentation installation complete."

However, with PostgreSQL 14.13 this is not the case anymore. (At least on Red Hat 9.4).
Is there any reason why this messages do not show up anymore? I found them quite useful.

Cheers
William

________________________________

Disclaimer:

Diese Nachricht und ihr eventuell angehängte Dateien sind nur für den Adressaten bestimmt. Sie kann vertrauliche oder gesetzlich geschützte Daten oder Informationen beinhalten. Falls Sie diese Nachricht irrtümlich erreicht hat, bitten wir Sie höflich, diese unter Ausschluss jeglicher Reproduktion zu löschen und die absendende Person zu benachrichtigen. Danke für Ihre Hilfe.

This message and any attached files are for the sole use of the recipient named above. It may contain confidential or legally protected data or information. If you have received this message in error, please delete it without making any copies whatsoever and notify the sender. Thank you for your assistance.

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 13 Aug 2024 14:12:51 +0200

On 13.08.24 10:07, William Sescu (Suva) wrote:
> There used to be messages like the following after running make or make 
> or make install-world, after the compilation of PostgreSQL.
> 

Here is the development discussion about it: 
https://www.postgresql.org/message-id/flat/6a421136-d462-b043-a8eb-e75b2861f3df%40dunslane.net

I guess the summary is that people preferred less chatter during the 
build, and that removing the messages made refactoring some make targets 
easier.

---

From: "William Sescu (Suva)" <[email-masked]>
Date: Tue, 13 Aug 2024 13:47:25 +0000

On 13.08.24 10:07, William Sescu (Suva) wrote:
> There used to be messages like the following after running make or
> make or make install-world, after the compilation of PostgreSQL.
>

> I guess the summary is that people preferred less chatter during the build, and that removing the messages made refactoring some make targets easier.

Thanks Peter for the clarification.

Disclaimer: