Subject: PostgreSQL LO

From: liam saffioti <[email-masked]>
Date: Sat, 16 Apr 2022 13:07:50 +0300

Hi Team,

I wonder about the large objects in postgresql. I have a database in
PostgreSQL 12 and there are many large object records in pg_largeobjects.
But I don't know how it was created. Also, I guess all large objects are
orphaned because they will be removed when I run vacuumlo command with the
dry run option on the database.

How do I find out the reason for how these large objects were created?

Also, I don't have any binary data on the database tables.

Cheers,
Liam

---

From: Laurenz Albe <[email-masked]>
Date: Sun, 17 Apr 2022 02:04:57 +0200

On Sat, 2022-04-16 at 13:07 +0300, liam saffioti wrote:
> I wonder about the large objects in postgresql. I have a database in PostgreSQL 12
> and there are many large object records in pg_largeobjects. But I don't know how it
> was created. Also, I guess all large objects are orphaned because they will be
> removed when I run vacuumlo command with the dry run option on the database.
> 

You'll have to ask the people who created and used the database.

Yours,
Laurenz Albe