Subject: The State of PostgreSQL 2021 survey results

From: Oleksii Kliukin <[email-masked]>
Date: Fri, 14 May 2021 10:46:15 +0200

Hi,

Timescale (my employer) has published the results of the State of PostgreSQL
2021 survey. You may find them at

https://tsdb.co/state-of-pg-2021

both the full report and the anonymized raw data (at the end of the report).

It aggregates the answers of 445 people and is a successor to the original
report published in 2019. The team has spent a lot of work compiling the
questions, processing the answers, designing and publishing the report, and
providing notes and explanations.

It would be super-interesting to get new interpretations of the results from
the folks in the community; I’ll pass praises, critics, and suggestions to
the team as well :-)

Kind regards,
--
Oleksii Kliukin
[email-masked]

---

From: Katherine Mcmillan <[email-masked]>
Date: Fri, 14 May 2021 11:20:57 +0000

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Katherine Mcmillan <[email-masked]>
Sent: Friday, May 14, 2021 7:17:50 AM
To: Oleksii Kliukin <[email-masked]>
Subject: Re: The State of PostgreSQL 2021 survey results

Hi Oleksii,

I would have loved to participate in this survey. How did participants in the survey find out about it?

Could you please provide any breakdowns you may have regarding the demographics of the participants? Ex. Percent female, percent working in the public sector? What all languages was it offered in?

Thank you,
Katie
Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Oleksii Kliukin <[email-masked]>
Sent: Friday, May 14, 2021 4:46:15 AM
To: [email-masked] <[email-masked]>
Subject: The State of PostgreSQL 2021 survey results

Attention : courriel externe | external email

Hi,

Kind regards,
--
Oleksii Kliukin
[email-masked]

---

From: Oleksii Kliukin <[email-masked]>
Date: Fri, 14 May 2021 15:26:50 +0200

Hi Katherine,

> I would have loved to participate in this survey. How did participants in the survey find out about it?

There were multiple channels,I think there is a good answer in the survey itself:

During that time, 445 people provided responses, which we (Timescale)
aggregated to generate this report. In addition to sending the survey to
past participants, we promoted the survey on social media, email newsletters
(our own and 3rd party), TimescaleDB and Postgres Slack channels, Postgres
mailing lists, Reddit, and Hacker News.

We also promoted it on Twitter.

> Could you please provide any breakdowns you may have regarding the demographics of the participants? Ex. Percent female, percent working in the public sector? What all languages was it offered in?

It has been offered in English only. I don’t have any extra data points
apart from what is published in the raw data, particularly we didn’t ask the
gender of the participants or whether they have public sector jobs.

Kind regards,
--
Oleksii Kliukin
[email-masked]

---

From: Justin Clift <[email-masked]>
Date: Sat, 15 May 2021 13:41:51 +1000

Interesting.  Might be worth adding an item for the next one's ToDo 
list,
of "let people on the pgsql-advocacy mailing list know about it too. :)

+ Justin

On 2021-05-14 23:26, Oleksii Kliukin wrote:
>> Could you please provide any breakdowns you may have regarding the 
>> demographics of the participants? Ex. Percent female, percent working 
>> in the public sector? What all languages was it offered in?
> 
>