Subject: PostgreSQL 15 release announcement draft

From: "Jonathan S. Katz" <[email-masked]>
Date: Tue, 30 Aug 2022 15:59:19 -0400

Hi,

Please see the first draft for the PostgreSQL 15 release announcement. 
This is the announcement that goes out when we ship 15.0.

A few notes on the first draft:

1. I have not put in any links yet -- I want to ensure the document is 
close to being static before I add those in.

2. I have left in a blurb about SQL/JSON while awaiting the decision on 
if the feature is included in v15.

Please provide feedback no later than 2022-09-10 0:00 AoE[1]. After this 
date, we will begin assembling the presskit that includes the translations.

Thanks,

Jonathan

[1] https://en.wikipedia.org/wiki/Anywhere_on_Earth

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Mon, 12 Sep 2022 12:53:45 -0400

On 8/30/22 3:59 PM, Jonathan S. Katz wrote:
> we will begin assembling the presskit that includes the translations.

Here is a (penultimate?) draft that includes URLs. Please provide any 
additional feedback no later than 2022-09-14 0:00 AoE. After that, we 
will begin the translation process.

Thanks,

Jonathan

---

From: Alvaro Herrera <[email-masked]>
Date: Mon, 12 Sep 2022 19:18:59 +0200

On 2022-Sep-12, Jonathan S. Katz wrote:

> ### More Options with Logical Replication
> 
> PostgreSQL 15 provides more flexibility for managing
> [logical replication](https://www.postgresql.org/docs/15/logical-replication.html).
> This release introduces
> [row filtering](https://www.postgresql.org/docs/15/logical-replication-row-filter.html)
> and
> [column filtering](https://www.postgresql.org/docs/15/sql-createpublication.html)
> for
> [publishers](https://www.postgresql.org/docs/15/logical-replication-publication.html),
> letting users choose to replicate a subset of data from a table. PostgreSQL 15
> adds features to simplify
> [conflict management](https://www.postgresql.org/docs/15/logical-replication-conflicts.html),
> including the ability to skip replaying a conflicting transaction and to
> automatically disable a subscription if an error is detected. This release also
> includes support for using two-phase commit (2PC) with logical replication.

We avoid the term "column filtering" here; we talk about column lists.
Maybe it could be "This release introduces row filtering for publishers
and the ability to specify an optional column list for each table".
Also, there are docs to this feature:
https://www.postgresql.org/docs/devel/logical-replication-col-lists.html

> ### Logging and Configuration Enhancements
> 
> PostgreSQL 15 introduces a new logging format:
> [`jsonlog`](https://www.postgresql.org/docs/15/runtime-config-logging.html#RUNTIME-CONFIG-LOGGING-JSONLOG).
> This new format outputs log data using a defined JSON structure, which allows
> PostgreSQL logs to be processed in structured logging systems. This release also
> adds a new built-in extension,
> [`pg_walinspect`](https://www.postgresql.org/docs/15/pgwalinspect.html), that
> lets users inspect the contents of write-ahead log files directly from a SQL
> interface.

It's very strange to have jsonlog and pg_walinspect in the same
paragraph.  Also, pg_walinspect isn't either logging or configuration.
Maybe put it under "other notable changes"?

-- 
Álvaro Herrera        Breisgau, Deutschland  —  https://www.EnterpriseDB.com/

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Mon, 12 Sep 2022 15:24:43 -0400

> and the ability to specify an optional column list for each table".

I can update this -- will do so in the next pass.

> https://www.postgresql.org/docs/devel/logical-replication-col-lists.html

Are they backpatched? They don't appear to be here, and a quick scan of 
REL_15_STABLE doesn't seem to show them:

https://www.postgresql.org/docs/15/logical-replication.html

> Maybe put it under "other notable changes"?

Agree that it's strange to put them together. That said, WAL is a form 
of logging (and a very important one at that ;)

I'm fine with pushing it into "other notable changes". Will update with 
another draft later.

Jonathan

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Mon, 12 Sep 2022 15:55:21 -0400

> I can update this -- will do so in the next pass.

I've made changes per the feedback from you, Peter, & Justin.

> https://www.postgresql.org/docs/15/logical-replication.html

I did a better scan and saw it was backpatched here, post Beta 4 tag[1]. 
I captured the link in the docs, but will double-check once RC1 is out.

Please review and let me know your thoughts.

Thanks,

Jonathan

[1] 
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=25996a82a44629bdedeae73b36c37ee35b37e9fe