Subject: PostgreSQL 14 press release draft

From: "Jonathan S. Katz" <[email-masked]>
Date: Mon, 20 Sep 2021 22:19:13 -0400

Hi,

Attached is a copy of the first draft for the PG14 press release.

This brings together highlights of many of the features in the upcoming
PostgreSQL 14 release while providing context on their significance.
With the plethora of new features coming in PostgreSQL 14, it is
challenging to highlight them all, but the idea is to give a glimpse of
what to expect in the new release.

Feedback on the release is welcome. However, please provide your
feedback on the release no later than **Thu, Sep 23, 2021 @ 18:00 UTC**.

Thanks,

Jonathan

---

From: Laurenz Albe <[email-masked]>
Date: Tue, 21 Sep 2021 09:16:58 +0200

On Mon, 2021-09-20 at 22:19 -0400, Jonathan S. Katz wrote:
> The [extended systems](https://www.postgresql.org/docs/14/planner-stats.html#PLANNER-STATS-EXTENDED)
> includes many improvements in PostgreSQL 14, including the ability to apply
> extend statistics on expressions. Additionally,
> [window functions](https://www.postgresql.org/docs/14/functions-window.html) can
> now benefit from incremental sorts, a feature that was introduced in
> [PostgreSQL 13](https://www.postgresql.org/about/news/postgresql-13-released-2077/).

"The extended systems" sounds weird to me, and the link points to extended statistics.

Did you mean to say "Extended statistics include many ..."?
But then the repetition jars.

Perhaps:

  [Extended statistics](https://www.postgresql.org/docs/14/planner-stats.html#PLANNER-STATS-EXTENDED)
  can be used for expressions in PostgreSQL v14.  Additionally,
  [window functions](https://www.postgresql.org/docs/14/functions-window.html) can
  now benefit from incremental sorts, a feature that was introduced in
  [PostgreSQL 13](https://www.postgresql.org/about/news/postgresql-13-released-2077/).

Yours,
Laurenz Albe

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Wed, 22 Sep 2021 10:18:27 -0400

>   [PostgreSQL 13](https://www.postgresql.org/about/news/postgresql-13-released-2077/).

Thanks, I mostly followed this suggestion. Please see attached for
updated draft, which also incorporates feedback from -hackers.

As a reminder, please provide any feedback on the press release no later
than **Thu, Sep 23, 2021 @ 18:00 UTC**.

Thanks,

Jonathan