Subject: Re: community social media

From: ourdiaspora <[email-masked]>
Date: Sat, 26 Sep 2020 10:11:18 +0000

Mail list readers,

Firstly, within the mailing list web pages, references to "blacklist"???

Mmm...

Anyway, please include with greater prominence, the existence of community social media platforms such as Hubzilla, Mastodon, Diaspora.

---

From: "David G. Johnston" <[email-masked]>
Date: Sat, 26 Sep 2020 09:04:24 -0700

> Firstly, within the mailing list web pages, references to "blacklist"???

Maybe provide a link to where and a suggested alternative wording.

Anyway, please include with greater prominence, the existence of community
> social media platforms such as Hubzilla, Mastodon, Diaspora.
>

If you know that these things exist you should provide links to them, and
suggest where you think "prominent" is on our site.

David J.

---

From: ourdiaspora <[email-masked]>
Date: Sat, 26 Sep 2020 18:05:14 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Saturday, September 26, 2020 5:04 PM, David G. Johnston <[email-masked]> wrote:

> On Sat, Sep 26, 2020 at 3:11 AM ourdiaspora <[email-masked]> wrote:
>
> > Mail list readers,
> >

See title 'Manage email addresses' after sign-in to your postgresql web site account

"allowed", "dis-allowed" could suffice

> If you know that these things exist you should provide links to them, and suggest where you think "prominent" is on our site.
>

Some examples:

https://fediverse.party/en/portal/servers
https://diasporafoundation.org
https://joinmastodon.org/

Postgresql home web page should have hyperlinks to official postgresql servers for these services.

So, next to the home page which shows:
https://twitter.com/postgresql

There should be:

https://postgresql.org/mastodon
https://postgresql.org/hubzilla
etc.

Of course, each community social media service should describe the postgreqsl configuration.

---

From: Adrian Klaver <[email-masked]>
Date: Sat, 26 Sep 2020 12:17:20 -0700

> "allowed", "dis-allowed" could suffice

Still not sure what the issue is.

-- 
Adrian Klaver
[email-masked]

---

From: Christophe Pettus <[email-masked]>
Date: Sat, 26 Sep 2020 12:25:19 -0700

> On Sep 26, 2020, at 12:17, Adrian Klaver <[email-masked]> wrote:
> 

On this page:

	https://lists.postgresql.org/manage/

In the section "Manage email addresses", the text reads in part:

	You can also blacklist your own email address from the lists.

"Blacklist" is an increasingly disfavored term.  I think "block" or "disallow" are both reasonable alternatives.

I'm moving this from -advocacy to -www, since that's a more appropriate list to discuss the change.

--
-- Christophe Pettus
   [email-masked]

---

From: ourdiaspora <[email-masked]>
Date: Sat, 26 Sep 2020 19:50:05 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Saturday, September 26, 2020 8:17 PM, Adrian Klaver <[email-masked]> wrote:

> > On Saturday, September 26, 2020 5:04 PM, David G. Johnston [email-masked] wrote:
> >
> > > On Sat, Sep 26, 2020 at 3:11 AM ourdiaspora [email-masked] wrote:
> > >
> > > > Mail list readers,

https://toot.thoughtworks.com/@judeswae/104571211206394579

Ignorance is bliss...

>
> -------------------------------------
>
> Adrian Klaver

---

From: Magnus Hagander <[email-masked]>
Date: Sat, 26 Sep 2020 22:04:53 +0200

On Sat, Sep 26, 2020 at 9:25 PM Christophe Pettus <[email-masked]> wrote:

> "Blacklist" is an increasingly disfavored term.  I think "block" or
> "disallow" are both reasonable alternatives.
>
There is already work in progress to get this replaced. There are some
backend considerations as well which is why it's not just a search/replace
(and not fixing those would make it inconsistent), but it's been on the
list for a while to get sorted out so it's definitely on people's radar.

-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>

---

From: Tomas Vondra <[email-masked]>
Date: Sat, 26 Sep 2020 22:06:44 +0200

>https://toot.thoughtworks.com/@judeswae/104571211206394579

Ummm, are you sure the best way to change things is to go to a mailing
list and insult people who may be genuinely confused about what exactly
you're proposing?

In any case, this list is meant to deal with promoting PostgreSQL
itself, so maybe a better place to discuss this is pgsql-www, which is
where the people maintaining the websites are paying more attention.

regards

-- 
Tomas Vondra                  http://www.2ndQuadrant.com
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

---

From: Dave Cramer <[email-masked]>
Date: Sat, 26 Sep 2020 16:11:57 -0400

> list and insult people who may be genuinely confused about what exactly

Ironic isn't it ?

Dave

---

From: "David G. Johnston" <[email-masked]>
Date: Sat, 26 Sep 2020 13:14:21 -0700

On Sat, Sep 26, 2020 at 11:05 AM ourdiaspora <[email-masked]>
wrote:

> > > Anyway, please include with greater prominence, the existence of
> community social media platforms such as Hubzilla, Mastodon, Diaspora.
> >
> > If you know that these things exist you should provide links to them,
> and suggest where you think "prominent" is on our site.
> >
>
> Some examples:
>
>

But I don't believe that there are official PostgreSQL servers for/on these
platforms (and it seems difficult to know whether there are unofficial
ones).  We do have Slack and IRC setup and links to those are on the
"Community" page.

David J.

---

From: Tomas Vondra <[email-masked]>
Date: Sat, 26 Sep 2020 22:21:52 +0200

>Postgresql home web page should have hyperlinks to official postgresql servers for these services.

I'm not sure there are official (i.e. operated by PGDG) postgresql
servers for these services.

>https://postgresql.org/hubzilla

Those links lead nowhere, so it's not clear to me what exactly is your
proposal? Are you suggesting PGDG should start running those services?
I very much doubt PGDG has the resources (esp. manpower) to run and
maintain every possible service of this kind ...

>postgreqsl configuration.

Not sure what you mean by this? What postgresql configuration?

regards

---

From: Adrian Klaver <[email-masked]>
Date: Sat, 26 Sep 2020 13:59:11 -0700

On 9/26/20 12:50 PM, ourdiaspora wrote:
> Ignorance is bliss..

I would say ignorance is taking a word(black) and appropriating it for a 
cause, wherever it appears, when said word has more them one meaning.

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Sat, 26 Sep 2020 17:48:32 -0400

> cause, wherever it appears, when said word has more them one meaning.

As Magnus said[1] a bit earlier, there's already an in-progress item to
implement language updates on pglister, but it's not a trivial change.

Now that we're passed the PostgreSQL 13 release (which for who track
things with the pgweb ecosystem, *a lot* of changes were added to help
support the release ;) my guess is this will be handled in the
not-too-distant future.

Suffice to say, this is being addressed.

Thanks,

Jonathan

[1]
https://www.postgresql.org/message-id/CABUevEyS0_xFc-7ZaWKR%3Dd5h-HfvGEt%2BPhEP2Dpp5H7sTxY6Ug%40mail.gmail.com

---

From: ourdiaspora <[email-masked]>
Date: Sun, 27 Sep 2020 08:25:42 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Saturday, September 26, 2020 9:06 PM, Tomas Vondra <[email-masked]> wrote:

> > On Saturday, September 26, 2020 8:17 PM, Adrian Klaver [email-masked] wrote:
> >
> > >

You should be sure that denialism per se is an insult to some

---

From: ourdiaspora <[email-masked]>
Date: Sun, 27 Sep 2020 08:31:05 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Saturday, September 26, 2020 9:14 PM, David G. Johnston <[email-masked]> wrote:

>
> But I don't believe that there are official PostgreSQL servers for/on these platforms (and it seems difficult to know whether there are unofficial ones).

Unofficial servers may be found via tags. Agree that's it's difficult to find within the fediverse (which is why the suggestion is made that official postgresql domains within the fediverse are created).

Example public "tags" that refer to postgresql:

https://mastodon.org.uk/tags/postgresql
https://mastodon.social/tags/postgresql

---

From: ourdiaspora <[email-masked]>
Date: Sun, 27 Sep 2020 08:43:53 +0000

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Saturday, September 26, 2020 9:04 PM, Magnus Hagander <[email-masked]> wrote:

> There is already work in progress to get this replaced. There are some backend considerations as well which is why it's not just a search/replace (and not fixing those would make it inconsistent), but it's been on the list for a while to get sorted out so it's definitely on people's radar.

Interesting; suggests the efficiency of achieving as much equity as possible at the first opportunity, to avoid the "replacement" requirement later. A quick look at the mailing lists, "pg-women" existence also indicative of a historical problem. At least acknowledgement to begin action is better than denialism, so this is good to read.