Subject: postgres.jar

From: Clive Swan <[email-masked]>
Date: Thu, 5 Jan 2023 12:39:15 +0000

Greetings,

I downloaded and copied the postgres.jar file into >>
sqldeveloper>lib>ext

It is in the same folder as dbtools-liquibase.jar

When I open Oracle SqlDeveloper I don't get the Postgres database dropdown??
Any suggestions on how to resolve this, appreciated.

-- 

 Regards,

Clive Swan

--

---

From: Dave Cramer <[email-masked]>
Date: Thu, 5 Jan 2023 07:41:11 -0500

Hi Clive,

The correct list for this is the pgsql-jdbc list.

I'd need to know more. Which jar? Where did you get it from ?

Dave Cramer
www.postgres.rocks

---

From: Clive Swan <[email-masked]>
Date: Thu, 5 Jan 2023 12:44:54 +0000

Hi Dave
Thanks for pointing me to the correct email list.

I downloaded the jar files from https://jdbc.postgresql.org/download/
file = postgresql-42.2.27.jre6.jar

-- 

 Regards,

Clive Swan

--

M: +44 7766 452665

---

From: Dave Cramer <[email-masked]>
Date: Thu, 5 Jan 2023 07:53:10 -0500

Are you using java 6 ?
Dave Cramer
www.postgres.rocks

---

From: Clive Swan <[email-masked]>
Date: Thu, 5 Jan 2023 14:01:17 +0000

Hi Dave,
I downloaded the package for Mac ARM64 Version: 22.2.1.234.1810
It doesn't say what Java version,  I downloaded the postgres jar file for
6, 7 and 8.
Hoped one would work

Thanks
Clive

-- 

 Regards,

Clive Swan

--

M: +44 7766 452665

---

From: Dave Cramer <[email-masked]>
Date: Thu, 5 Jan 2023 09:12:01 -0500

Well you need to match the postgresql jar to the version of java you are
using.

Dave Cramer
www.postgres.rocks

---

From: Clive Swan <[email-masked]>
Date: Thu, 5 Jan 2023 14:20:50 +0000

Oracle SQL Developer About returns: Java(TM) Platform 11.0.16.1
Postgres.jar are 6 - 8
I don't see any Java package that matches 11??

-- 

 Regards,

Clive Swan

--

M: +44 7766 452665

---

From: Dave Cramer <[email-masked]>
Date: Thu, 5 Jan 2023 09:21:24 -0500

8 will match.
Dave Cramer
www.postgres.rocks

On Thu, 5 Jan 2023 at 09:20, Clive Swan <[email-masked]> wrote:

>>> It doesn't say what Java version,  I downloaded the postgres jar file
>>> for 6, 7 and 8.
>>> Hoped one would work
>>>
>>> Thanks
>>> Clive
>>>

---

From: Clive Swan <[email-masked]>
Date: Thu, 5 Jan 2023 14:29:47 +0000

Hi Dave,
I have postgresql-42.5.1.jar (8) under folder:
/Applications/SQLDeveloper.app/Contents/Resources/sqldeveloper/sqldeveloper/lib/ext

Still doesn't appear to have activated, do I need to run a Mac/Linux
command to get it "*active*"??

-- 

 Regards,

Clive Swan

--

M: +44 7766 452665

---

From: Dave Cramer <[email-masked]>
Date: Thu, 5 Jan 2023 09:32:02 -0500

There is nothing to activate. It should just work.
I have no information about using SQLDeveloper, sorry.

Dave Cramer
www.postgres.rocks

On Thu, 5 Jan 2023 at 09:29, Clive Swan <[email-masked]> wrote:

>>>> Well you need to match the postgresql jar to the version of java you
>>>> are using.
>>>>
>>>>
>>>> Dave Cramer
>>>> www.postgres.rocks
>>>>
>>>>

---

From: Justin Clift <[email-masked]>
Date: Fri, 06 Jan 2023 02:12:27 +1100

> Any suggestions on how to resolve this, appreciated.

Hey Clive,

Sorry to say, but this is very much the wrong mailing list
for this question.

While this one is indeed a "PostgreSQL" mailing list, it's
more about marketing and advocacy.

Thinking over your message though (I'm not a java guy), you
might want to resend it to the "pgsql-jdbc" mailing list:

   https://www.postgresql.org/list/pgsql-jdbc/   <-- archives

They likely have a better idea of how to do .jar things with
Postgres. :)

Regards and best wishes,

Justin Clift