Subject: What The... PostgreSQL "Activity Book" ;)

From: Justin Clift <[email-masked]>
Date: Tue, 03 Oct 2023 06:07:15 +1100

Just stumbled over something I never thought I'd see. ;)

There's a PostgreSQL "Activity Book" now.  Like, those books
for kids:

https://techcommunity.microsoft.com/t5/azure-database-for-postgresql/the-story-behind-the-activity-book-for-postgres/ba-p/3941372

And it's from MS of all places (!!!).

I guess we can say PG truly has a wide audience these days,
it's being introduced to kids. ;)

+ Justin

---

From: Robert Bernier <[email-masked]>
Date: Mon, 2 Oct 2023 14:41:27 -0700 (PDT)

I suppose it's a sign of the times, considering Oracle now supports PostgreSQL too ;-) 

Robert

> On 10/02/2023 12:07 PM PDT Justin Clift <[email-masked]> wrote:
> 
>

---

From: Katherine Mcmillan <[email-masked]>
Date: Mon, 2 Oct 2023 22:02:45 +0000

Hi Robert,

How does Oracle support PostgreSQL?

EDB has a "compatibility mode", but that's EDB.  Oracle has produced some documentation for PostgreSQL (ex. https://docs.oracle.com/en/solutions/deploy-postgresql-db/index.html).  You can deploy a PostgreSQL cluster on an Oracle Cloud Infrastructure.  Their "go to" still seems to be MySQL, but perhaps this has changed?

Could you please clarify would you mean by "supports"?

Thank you,
Katie
________________________________
From: Robert Bernier <[email-masked]>
Sent: 02 October 2023 17:41
To: Justin Clift <[email-masked]>; PostgreSQL Advocacy <[email-masked]>
Subject: Re: What The... PostgreSQL "Activity Book" ;)

Attention : courriel externe | external email

Robert

---

From: M Sarwar <[email-masked]>
Date: Mon, 2 Oct 2023 22:04:40 +0000

I do not.think that Oracle.will ever support Postgress.
Sarwar

Sent from my Galaxy

-------- Original message --------
From: Katherine Mcmillan <[email-masked]>
Date: 10/2/23 6:03 PM (GMT-05:00)
To: Robert Bernier <[email-masked]>, Justin Clift <[email-masked]>, PostgreSQL Advocacy <[email-masked]>
Subject: Re: What The... PostgreSQL "Activity Book" ;)

Hi Robert,

Thank you,
Katie

Robert

---

From: Katherine Mcmillan <[email-masked]>
Date: Mon, 2 Oct 2023 22:06:03 +0000

I really think it depends on what Robert means by "supports", and I'm really curious.

-Katie
________________________________
From: M Sarwar <[email-masked]>
Sent: 02 October 2023 18:04
To: Katherine Mcmillan <[email-masked]>; Robert Bernier <[email-masked]>; Justin Clift <[email-masked]>; PostgreSQL Advocacy <[email-masked]>
Subject: RE: What The... PostgreSQL "Activity Book" ;)

Sent from my Galaxy

-------- Original message --------
From: Katherine Mcmillan <[email-masked]>
Date: 10/2/23 6:03 PM (GMT-05:00)
To: Robert Bernier <[email-masked]>, Justin Clift <[email-masked]>, PostgreSQL Advocacy <[email-masked]>
Subject: Re: What The... PostgreSQL "Activity Book" ;)

Hi Robert,

Thank you,
Katie

Robert

---

From: Robert Bernier <[email-masked]>
Date: Mon, 2 Oct 2023 15:15:24 -0700 (PDT)

Yes it does ;-)
 
https://blogs.oracle.com/cloud-infrastructure/post/oci-database-postgres

> On 10/02/2023 3:04 PM PDT M Sarwar <[email-masked]> wrote:
>  
>  
> ---------------------------------------------
> > https://techcommunity.microsoft.com/t5/azure-database-for-postgresql/the-story-behind-the-activity-book-for-postgres/ba-p/3941372 https://techcommunity.microsoft.com/t5/azure-database-for-postgresql/the-story-behind-the-activity-book-for-postgres/ba-p/3941372
> >

---

From: M Sarwar <[email-masked]>
Date: Mon, 2 Oct 2023 22:24:56 +0000

I can understand.
Currently  I am  working Postgres on AWS platforms. aws is giving Postgres support without having any of it's own authentication on the Postgres. In my opinion, OCI will give similar type of support if OCI does.
Thanks,
Sarwar

________________________________
From: Robert Bernier <[email-masked]>
Sent: Monday, October 2, 2023 6:15 PM
To: M Sarwar <[email-masked]>; Katherine Mcmillan <[email-masked]>; Justin Clift <[email-masked]>; PostgreSQL Advocacy <[email-masked]>
Subject: RE: What The... PostgreSQL "Activity Book" ;)

Yes it does ;-)

Sent from my Galaxy

-------- Original message --------
From: Katherine Mcmillan <[email-masked]>
Date: 10/2/23 6:03 PM (GMT-05:00)
To: Robert Bernier <[email-masked]>, Justin Clift <[email-masked]>, PostgreSQL Advocacy <[email-masked]>
Subject: Re: What The... PostgreSQL "Activity Book" ;)

Hi Robert,

Thank you,
Katie

Robert

---

From: M Sarwar <[email-masked]>
Date: Mon, 2 Oct 2023 22:27:54 +0000

On this new arrival ( Postgress on OCI), this should be the cheapest approach to deploy Postgres on any Cloud.
I am saying this because OCI claims OCI is the cheapest cloud in the market. But this could be wrong claim as well.

Thanks,
Sarwar

________________________________
From: Katherine Mcmillan <[email-masked]>
Sent: Monday, October 2, 2023 6:02 PM
To: Robert Bernier <[email-masked]>; Justin Clift <[email-masked]>; PostgreSQL Advocacy <[email-masked]>
Subject: Re: What The... PostgreSQL "Activity Book" ;)

Hi Robert,

Thank you,
Katie

Robert

---

From: Justin Clift <[email-masked]>
Date: Wed, 04 Oct 2023 00:34:24 +1100

> https://blogs.oracle.com/cloud-infrastructure/post/oci-database-postgres

Wow, that's awesome.  Maybe a case of "if you can't beat them, join 
them". ;D

+ Justin

---

From: Devrim Gündüz <[email-masked]>
Date: Tue, 03 Oct 2023 18:41:45 -0400

Hi,

https://twitter.com/DevrimGunduz/status/1201074936200269826

:)

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: Michael Paquier <[email-masked]>
Date: Wed, 4 Oct 2023 08:30:39 +0900

> https://twitter.com/DevrimGunduz/status/1201074936200269826

If there are exemplaries of that in the area of Prague, around
December...  I'd love getting one. :D
--
Michael

---

From: Ian Lawrence Barwick <[email-masked]>
Date: Wed, 4 Oct 2023 14:00:04 +0900

> December...  I'd love getting one. :D

You might just be in luck, see:

Regards

Ian Barwick

---

From: Michael Paquier <[email-masked]>
Date: Wed, 4 Oct 2023 15:07:53 +0900

>   https://techcommunity.microsoft.com/t5/azure-database-for-postgresql/the-story-behind-the-activity-book-for-postgres/ba-p/3941372

イエイ。
--
Michael

---

From: Guillaume Lelarge <[email-masked]>
Date: Wed, 4 Oct 2023 13:26:37 +0200

> December...  I'd love getting one. :D

You should ask Claire Giordano (CC-ed). I got one from her at FOSDEM (2022
I guess?). That's when (and where) I discovered these activity books.

-- 
Guillaume.

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 6 Oct 2023 17:20:00 -0400

On Wed, Oct  4, 2023 at 01:26:37PM +0200, Guillaume Lelarge wrote:
> You should ask Claire Giordano (CC-ed). I got one from her at FOSDEM (2022 I
> guess?). That's when (and where) I discovered these activity books.

I just brought home the new edition from PGConf NYC for my wife.  :-)
She loves it.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Only you can decide what is important to you.

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 6 Oct 2023 17:20:26 -0400

> https://blogs.oracle.com/cloud-infrastructure/post/oci-database-postgres

My blog entry has more details:

	https://momjian.us/main/blogs/pgblog/2023.html#September_29_2023

---

From: Shane Ambler <[email-masked]>
Date: Sat, 7 Oct 2023 10:22:25 +1030

> 	https://momjian.us/main/blogs/pgblog/2023.html#September_29_2023

I think for some clarity ...

this started with "Oracle now supports PostgreSQL"

So "Oracle the company" does provide support for standard PostgreSQL
software running within an Oracle Cloud instance.

"Oracle the database" does not provide any support as far as
(non-standard) SQL compatibility with PostgreSQL schema designs or
functions/procedures etc

Then in the opposite direction, the EDB version of PostgreSQL does add
some level of SQL and cli support for running PostgreSQL as a
replacement for an Oracle DB backend.

-- 

Shane Ambler
pgSQL (at) Sheeky (dot) Biz

---

From: Katherine Mcmillan <[email-masked]>
Date: Sat, 7 Oct 2023 01:17:51 +0000

Hi Shane,

Not to be contrarian, but I think this started without Oracle... all of this.

As far as I can tell, this string started with an awesome post from Justin Clift that didn't have anything to do with Oracle:
"Just stumbled over something I never thought I'd see. ;)

https://techcommunity.microsoft.com/t5/azure-database-for-postgresql/the-story-behind-the-activity-book-for-postgres/ba-p/3941372
[https://techcommunity.microsoft.com/t5/image/serverpage/image-id/512277i58AE528486E0E8B5/image-size/original?v=v2&px=-1]<https://techcommunity.microsoft.com/t5/azure-database-for-postgresql/the-story-behind-the-activity-book-for-postgres/ba-p/3941372>
The Story Behind the Activity Book for Postgres<https://techcommunity.microsoft.com/t5/azure-database-for-postgresql/the-story-behind-the-activity-book-for-postgres/ba-p/3941372>
Read the story behind “An Activity Book for Postgres”. What inspired its creation? How can you get your own copy?
techcommunity.microsoft.com

+ Justin"

-Katie

________________________________
From: [email-masked] <[email-masked]> on behalf of Shane Ambler <[email-masked]>
Sent: 06 October 2023 19:52
To: PostgreSQL Advocacy <[email-masked]>; Bruce Momjian <[email-masked]>
Subject: Re: What The... PostgreSQL "Activity Book" ;)

--

Shane Ambler

---

From: Laurenz Albe <[email-masked]>
Date: Sat, 07 Oct 2023 14:35:14 +0200

> software running within an Oracle Cloud instance.

I don't know if they porvide support.  Cloud hosting companies are usually
not that interested in providing support.  They want their customers to pay
their monthly dues without generating any extra work for them.

And what I have been told about the development of the quality of Oracle
support in the last decade or so, support by Oracle doesn't sound exactly
appealing (beside the fact that they probably know little about PostgreSQL).

Yours,
Laurenz Albe

---

From: Shane Ambler <[email-masked]>
Date: Sun, 8 Oct 2023 09:33:59 +1030

> There's a PostgreSQL "Activity Book" now.  Like, those books

Actually I was only referring to this side thread of oracle support that
popped into that initial thread.

-- 

Shane Ambler

---

From: Shane Ambler <[email-masked]>
Date: Sun, 8 Oct 2023 09:40:48 +1030

> their monthly dues without generating any extra work for them.

Well from their product news -
https://blogs.oracle.com/cloud-infrastructure/post/expand-managed-open-source-services-on-oci

"OCI Database with PostgreSQL is a fully managed PostgreSQL database
service ..."

"Fully managed" should mean they keep the system and PostgreSQL running
and you only get to access the server as a client, so they have to
provide some level of support.

> appealing (beside the fact that they probably know little about PostgreSQL).
No one said their support was good ;) only that they offer it.

-- 

Shane Ambler