Received: from malur.postgresql.org ([2a02:16a8:dc51::56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1foyb4-0007LG-0z for pgsql-bugs@arkaria.postgresql.org; Sun, 12 Aug 2018 22:12:26 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1foyb1-0000Tf-Vc for pgsql-bugs@arkaria.postgresql.org; Sun, 12 Aug 2018 22:12:23 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1foyb1-0000TX-PS for pgsql-bugs@lists.postgresql.org; Sun, 12 Aug 2018 22:12:23 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.89) (envelope-from ) id 1foyav-0006xA-1H for pgsql-bugs@lists.postgresql.org; Sun, 12 Aug 2018 22:12:23 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id w7CMCB6S022709; Sun, 12 Aug 2018 18:12:11 -0400 From: Tom Lane To: Andrew Gierth cc: Pavel Stehule , pgsql-bugs@lists.postgresql.org, Alvaro Herrera Subject: Re: BUG #15321: XMLTABLE leaks memory like crazy In-reply-to: <8736vj6zod.fsf@news-spur.riddles.org.uk> References: <153394403528.10284.7530399040974170549@wrigleys.postgresql.org> <87va8h7nyl.fsf@news-spur.riddles.org.uk> <87r2j57hdo.fsf@news-spur.riddles.org.uk> <87k1ow6o7i.fsf@news-spur.riddles.org.uk> <87ftzk6jw2.fsf@news-spur.riddles.org.uk> <87bma77v67.fsf@news-spur.riddles.org.uk> <877ekv7s9j.fsf@news-spur.riddles.org.uk> <17553.1534086692@sss.pgh.pa.us> <8736vj6zod.fsf@news-spur.riddles.org.uk> Comments: In-reply-to Andrew Gierth message dated "Sun, 12 Aug 2018 22:30:33 +0100" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <22707.1534111931.1@sss.pgh.pa.us> Date: Sun, 12 Aug 2018 18:12:11 -0400 Message-ID: <22708.1534111931@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Andrew Gierth writes: > "Tom" == Tom Lane writes: > Tom> Also, I'd be inclined to rename "perValueCxt" to something else, > Tom> it's not really correctly named for this usage pattern. > perCallCxt? or do you have a better name? I was hoping to avoid being pinned down on that ;-). But maybe fetchRowsCxt or tableBuildCxt or something along that line? It's not very clear what "perCall" is per call of, so I'm not in love with that idea. regards, tom lane