Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1iiX2I-00054E-Ud for pgsql-bugs@arkaria.postgresql.org; Sat, 21 Dec 2019 05:10:43 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.89) (envelope-from ) id 1iiX2H-0002iN-72 for pgsql-bugs@arkaria.postgresql.org; Sat, 21 Dec 2019 05:10:41 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA1:256) (Exim 4.89) (envelope-from ) id 1iiX2G-0002iG-LP for pgsql-bugs@lists.postgresql.org; Sat, 21 Dec 2019 05:10:40 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by makus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1iiX2E-0005gH-55 for pgsql-bugs@lists.postgresql.org; Sat, 21 Dec 2019 05:10:39 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id xBL5AVYd029717; Sat, 21 Dec 2019 00:10:31 -0500 From: Tom Lane To: Thomas Munro cc: Tomas Vondra , Alvaro Herrera , Andres Freund , James Coleman , PostgreSQL mailing lists Subject: Re: BUG #16104: Invalid DSA Memory Alloc Request in Parallel Hash In-reply-to: References: <20191210173224.y5vaam6ep7pjmddt@development> <20191210173516.GA10987@alvherre.pgsql> <20191210183606.t26c5ypa7bmij3ph@development> Comments: In-reply-to Thomas Munro message dated "Sat, 21 Dec 2019 16:02:28 +1300" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <29715.1576905031.1@sss.pgh.pa.us> Date: Sat, 21 Dec 2019 00:10:31 -0500 Message-ID: <29716.1576905031@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Precedence: bulk Thomas Munro writes: > I ran the 150MB 4096 batch "sevenb" self-join with the "rotate" patch, > and it worked as expected. I'm now planning to commit that version, > unless there are objections or someone wants to argue for a different > way to spell rotate() etc. FWIW, I do want to argue for a different way to spell that. It seems like a mighty generic function name --- in particular, there's no hint of the word width we're rotating in. Maybe "rotate32" would be good enough, though I'm tempted to propose "pg_rotate32" or "rotate_bit32" or some other variation on that. regards, tom lane