Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1odB55-0003kk-Qj for pgsql-bugs@arkaria.postgresql.org; Tue, 27 Sep 2022 13:57:03 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1odB54-0005nT-Ef for pgsql-bugs@arkaria.postgresql.org; Tue, 27 Sep 2022 13:57:02 +0000 Received: from makus.postgresql.org ([2001:4800:3e1:1::229]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1odB54-0005nJ-6E for pgsql-bugs@lists.postgresql.org; Tue, 27 Sep 2022 13:57:02 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by makus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1odB51-0003mX-7C for pgsql-bugs@lists.postgresql.org; Tue, 27 Sep 2022 13:57:01 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 28RDuvpl3667395; Tue, 27 Sep 2022 09:56:57 -0400 From: Tom Lane To: Michael Paquier cc: Masahiko Sawada , Justin Pryzby , Dmitry Koval , Dilip Kumar , andrewbille@gmail.com, pgsql-bugs@lists.postgresql.org, Kyotaro Horiguchi Subject: Re: BUG #17385: "RESET transaction_isolation" inside serializable transaction causes Assert at the transaction end In-reply-to: References: <20220628003720.GG19662@telsasoft.com> <2604497.1664053071@sss.pgh.pa.us> <3268290.1664165270@sss.pgh.pa.us> Comments: In-reply-to Michael Paquier message dated "Tue, 27 Sep 2022 12:39:28 +0900" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <3667393.1664287017.1@sss.pgh.pa.us> Date: Tue, 27 Sep 2022 09:56:57 -0400 Message-ID: <3667394.1664287017@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk Michael Paquier writes: > As we are talking about a description with GUC_ACTION_SAVE, something > like "Parameters with this flag do not support RESET, or SET in the > context of a function call"? NO_RESET sounds a bit confusing as a > name if you consider this second part (it can be understood as > resetting the value as well), but keeping it as-is does not look like > a big deal to me with this description, or an equivalent, in place. Yeah, we already talked upthread about how the SAVE restriction makes "NO_RESET" a bit of a misnomer. Nobody proposed a better name though. regards, tom lane