Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1uttoo-00FjMA-Kh for pgsql-bugs@arkaria.postgresql.org; Wed, 03 Sep 2025 20:10:59 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.94.2) (envelope-from ) id 1utton-00BRnl-Nr for pgsql-bugs@arkaria.postgresql.org; Wed, 03 Sep 2025 20:10:58 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.94.2) (envelope-from ) id 1utton-00BRnd-Ef for pgsql-bugs@lists.postgresql.org; Wed, 03 Sep 2025 20:10:57 +0000 Received: from sss.pgh.pa.us ([68.162.161.243]) by magus.postgresql.org with esmtps (TLS1.3) tls TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 (Exim 4.96) (envelope-from ) id 1uttok-000PQI-1v for pgsql-bugs@lists.postgresql.org; Wed, 03 Sep 2025 20:10:57 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 583KAq1n901578; Wed, 3 Sep 2025 16:10:52 -0400 From: Tom Lane To: =?utf-8?Q?=C3=81lvaro?= Herrera cc: d.kovalenko@postgrespro.ru, pgsql-bugs@lists.postgresql.org Subject: Re: BUG #18960: Mistake in test test_simple_pipeline (libpq_pipeline.c) In-reply-to: <202509031706.ojnhzuyakuo4@alvherre.pgsql> References: <202509031706.ojnhzuyakuo4@alvherre.pgsql> Comments: In-reply-to =?utf-8?Q?=C3=81lvaro?= Herrera message dated "Wed, 03 Sep 2025 19:06:02 +0200" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <901576.1756930252.1@sss.pgh.pa.us> Date: Wed, 03 Sep 2025 16:10:52 -0400 Message-ID: <901577.1756930252@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk =?utf-8?Q?=C3=81lvaro?= Herrera writes: > On 2025-Sep-03, Tom Lane wrote: >> Hm, I chose that name by analogy to the adjacent >> confirm_query_canceled(), which is likewise consuming a result. >> I agree that "consume" is a better verb, but then let's rename >> confirm_query_canceled as well. > Ah, that explains it -- my bad, then, I suppose. That change works for > me. After reflection, I used "consume_xxx" for the void-returning helper functions, but kept the "confirm_xxx" terminology for the helper function that returns a PGresult after confirming its status is as-expected. Pushed with those renamings. regards, tom lane