Subject: Re: BUG #19436: Azure Arc installation failure

From: Magnus Hagander <[email-masked]>
Date: Tue, 17 Mar 2026 17:11:40 +0100

On Tue, 17 Mar 2026 at 17:06, PG Bug reporting form <[email-masked]>
wrote:

> The following bug has been logged on the website:
>
> Bug reference:      19436
> Logged by:          Richard Devey
> Email address:      [email-masked]
> PostgreSQL version: Unsupported/Unknown
> Operating system:   Oracle Linux 8
> Description:
>
> The scripts for this installation call on a directory named "13" in this
> location:
> download.postgresql.org/pub/repos/yum/
>
> That directory is missing which is causing Azure ARC installations to fail.
>
> Full path is:
>
> https://download.postgresql.org/pub/repos/yum/13/redhat/rhel-8-x86_64/repodata/repomd.xml
>
>
Hello!

PostgreSQL 13 is end-of-life since last year, and not provided on the main
downloads anymore. There is an archived version on yum-archive, but it's
unsupported, and you should really use a supported version.

//Magnus

---

From: "Devey, Richard" <[email-masked]>
Date: Tue, 17 Mar 2026 17:46:14 +0000

It is not our company utilizing that old build - we believe it is Microsoft.

They are providing us a script to install Azure ARC.
When we run that script, it calls another script we are unable to see or modify and that is where it is calling that "13" directory.

Is there any way to have that restored until vendors can adjust their installation scripts?

Richard

From: Magnus Hagander <[email-masked]>
Sent: Tuesday, March 17, 2026 12:12 PM
To: Devey, Richard <[email-masked]>; [email-masked]
Subject: Re: BUG #19436: Azure Arc installation failure

You don't often get email from [email-masked]<mailto:[email-masked]>. Learn why this is important<https://aka.ms/LearnAboutSenderIdentification>

WARNING - External email; exercise caution

On Tue, 17 Mar 2026 at 17:06, PG Bug reporting form <[email-masked]<mailto:[email-masked]>> wrote:
The following bug has been logged on the website:

Bug reference:      19436
Logged by:          Richard Devey
Email address:      [email-masked]<mailto:[email-masked]>
PostgreSQL version: Unsupported/Unknown
Operating system:   Oracle Linux 8
Description:

The scripts for this installation call on a directory named "13" in this
location:
download.postgresql.org/pub/repos/yum/<http://download.postgresql.org/pub/repos/yum/>

Full path is:

Hello!

PostgreSQL 13 is end-of-life since last year, and not provided on the main downloads anymore. There is an archived version on yum-archive, but it's unsupported, and you should really use a supported version.

//Magnus

---

From: John Naylor <[email-masked]>
Date: Thu, 19 Mar 2026 09:23:25 +0700

On Wed, Mar 18, 2026 at 7:08 PM Devey, Richard <
[email-masked]> wrote:
>
> It is not our company utilizing that old build – we believe it is
Microsoft.

> When we run that script, it calls another script we are unable to see or
modify and that is where it is calling that “13” directory.

The provider of the script is responsible for its functionality, not us.

--
John Naylor
Amazon Web Services