Subject: Error "could not access status of transaction" - version 14.21

From: Aaron Caskey-Demaret <[email-masked]>
Date: Thu, 19 Feb 2026 14:47:18 +0000

Hi,

When replicating to version 14.21 from version 14.20 we encountered the following error:

2026-02-19 12:22:36.927 CET [4005-295] FATAL:  could not access status of transaction 13690880
2026-02-19 12:22:36.927 CET [4005-296] DETAIL:  Could not read from file "pg_multixact/offsets/00D0" at offset 237568: read too few bytes.
2026-02-19 12:22:36.927 CET [4005-297] CONTEXT:  WAL redo at 27E6A/15BFDE98 for MultiXact/CREATE_ID: 13690879 offset 27490069 nmembers 2: 616733495 (keysh) 616733515 (keysh)
2026-02-19 12:22:37.928 CET [2582-6] LOG:  startup process (PID 4005) exited with exit code 1
2026-02-19 12:22:37.928 CET [2582-7] LOG:  terminating any other active server processes
2026-02-19 12:22:40.622 CET [2582-8] LOG:  shutting down due to startup process failure
2026-02-19 12:22:44.994 CET [2582-9] LOG:  database system is shut down

The server would restart, but the issue would crop up again within 30 mins (different offsets)

After rolling back to version 14.20 the environment is stable again.

I'm guessing this is the exact same issue as https://www.postgresql.org/message-id/CACV2tSw3VYS7d27ftO_cs%2BaF3M54%2BJwWBbqSGLcKoG9cvyb6EA%40mail.gmail.com I just wanted to log that the issue is affecting other versions as well.

Regards

Aaron Caskey-Demaret

Site Reliability Engineer

[email-masked]

---

From: Kirill Reshke <[email-masked]>
Date: Thu, 19 Feb 2026 22:34:29 +0500

On Thu, 19 Feb 2026 at 21:37, Aaron Caskey-Demaret <
[email-masked]> wrote:

> 2026-02-19 12:22:36.927 CET [4005-296] DETAIL:  Could not read from file
> "pg_multixact/offsets/00D0" at offset 237568: read too few bytes.
> 2026-02-19 12:22:36.927 CET [4005-297] CONTEXT:  WAL redo at
> 27E6A/15BFDE98 for MultiXact/CREATE_ID: 13690879 offset 27490069 nmembers
> 2: 616733495 (keysh) 616733515 (keysh)
> I'm guessing this is the exact same issue as
> https://www.postgresql.org/message-id/CACV2tSw3VYS7d27ftO_cs%2BaF3M54%2BJwWBbqSGLcKoG9cvyb6EA%40mail.gmail.com I
> just wanted to log that the issue is affecting other versions as well.
>
> Regards
>
> *Aaron Caskey-Demaret*
>

Hi!
I beleive this is
https://www.postgresql.org/about/news/out-of-cycle-release-scheduled-for-february-26-2026-3241/
-- 
Best regards,
Kirill Reshke