Subject: BUG #19521: After a minor PostgreSQL update from 14.22 to 14.23, the database goes into an infinite loop.

From: PG Bug reporting form <[email-masked]>
Date: Mon, 15 Jun 2026 13:39:54 +0000

The following bug has been logged on the website:

Bug reference:      19521
Logged by:          Sergey Apoychenko
Email address:      [email-masked]
PostgreSQL version: 14.23
Operating system:   CentOS 7.9
Description:        

After a minor PostgreSQL update from 14.22 to 14.23 on a physical replica,
endless messages appear.

When starting the database
2026-06-15 15:17:27.331 [2582] [email-masked](58784) /postgres/
[unknown] |6a2fed57.a16|:2 (0): > DETAIL:  Consistent recovery state has not
been yet reached.
2026-06-15 15:17:28.543 [2584] [email-masked](58788) /postgres/
[unknown] |6a2fed58.a18|:1 (0): > FATAL:  the database system is not yet
accepting connections
2026-06-15 15:17:28.543 [2584] [email-masked](58788) /postgres/
[unknown] |6a2fed58.a18|:2 (0): > DETAIL:  Consistent recovery state has not
been yet reached.
2026-06-15 15:17:29.736 [2586] [email-masked](58792) /postgres/
[unknown] |6a2fed59.a1a|:1 (0): > FATAL:  the database system is not yet
accepting connections
2026-06-15 15:17:29.736 [2586] [email-masked](58792) /postgres/
[unknown] |6a2fed59.a1a|:2 (0): > DETAIL:  Consistent recovery state has not
been yet reached.
2026-06-15 15:17:32.329 [2589] [email-masked](58796) /postgres/
[unknown] |6a2fed5c.a1d|:1 (0): > FATAL:  the database system is not yet
accepting connections

When trying to stop the database
2026-06-15 15:20:33.445 [1803] @ //  |6a2fec4a.70b|:7 (0): > LOG:  received
fast shutdown request
2026-06-15 15:20:33.588 [3269] [email-masked](59146) /postgres/
[unknown] |6a2fee11.cc5|:1 (0): > FATAL:  the database system is shutting
down
2026-06-15 15:20:34.643 [3271] [email-masked](59150) /postgres/
[unknown] |6a2fee12.cc7|:1 (0): > FATAL:  the database system is shutting
down
2026-06-15 15:20:36.024 [3273] [email-masked](59154) /postgres/
[unknown] |6a2fee14.cc9|:1 (0): > FATAL:  the database system is shutting
down
2026-06-15 15:20:36.051 [3274] [email-masked](59158) /postgres/
[unknown] |6a2fee14.cca|:1 (0): > FATAL:  the database system is shutting
down
2026-06-15 15:20:40.009 [3282] [email-masked](59162) /postgres/
[unknown] |6a2fee18.cd2|:1 (0): > FATAL:  the database system is shutting
down
2026-06-15 15:20:51.059 [3291] [email-masked](59166) /postgres/
[unknown] |6a2fee23.cdb|:1 (0): > FATAL:  the database system is shutting
down

After rolling back to version 14.22, everything works as intended.

---

From: Andrey Borodin <[email-masked]>
Date: Mon, 15 Jun 2026 22:44:31 +0500

> On 15 Jun 2026, at 18:39, PG Bug reporting form <[email-masked]> wrote:
> 

Hi! Thanks for the report. Can you please give a bit more logs? This excerpt is
missing errors from the startup process. And message from this process could shed
a light on a root cause.

Best regards, Andrey Borodin.

---

From: Michael Paquier <[email-masked]>
Date: Tue, 16 Jun 2026 12:46:26 +0900

> missing errors from the startup process. And message from this process could shed

Looking at the set of changes in the range REL_14_22..REL_14_23, we
don't have many things related to recovery, so if you can provide more
details we will likely be able to point to a cause.  Without more
information there is nothing that we can unfortunately do.

One thing that I suspect is some custom extension code that may live
outside of core.  I have not heard about cases similar to the one
here, and it's been more than 4 weeks since this 14.23 has been
released.
--
Michael

---

From: Álvaro Herrera <[email-masked]>
Date: Tue, 16 Jun 2026 20:36:29 +0200

> missing errors from the startup process. And message from this process could shed

I suspect e35e466f61b [1] might be related.  That's a bug that was
fixed in 2bb60eb4fea [2], just after 14.23.

[1] https://postgr.es/c/e35e466f61b
[2] https://postgr.es/c/2bb60eb4fea

If not, some data from pg_waldump around the problem area might be useful.

-- 
Álvaro Herrera        Breisgau, Deutschland  —  https://www.EnterpriseDB.com/
"If you have nothing to say, maybe you need just the right tool to help you
not say it."                   (New York Times, about Microsoft PowerPoint)

---

From: Andrey Borodin <[email-masked]>
Date: Tue, 16 Jun 2026 23:43:12 +0500

> On 16 Jun 2026, at 23:36, Álvaro Herrera <[email-masked]> wrote:
> 

Yeah, that was my concern. But that bug manifests as startup process failure.
I've contacted Sergey offlist, he observed hanging

postgres: data: startup recovering 000000060000C29100000016

so it's hard to tell what's going on without backtrace...

---

From: Сергей Дм. Апойченко<[email-masked]>
Date: Wed, 17 Jun 2026 21:49:22 +0500

Good day to everyone!

Last night I performed a switchover in the cluster.

Today I tried to catch an error when updating 14.19 ==> 14.23 on the old primary, but everything worked as expected.

The database started and connected to the replication slot on the new primary.

##STANDBY_LOG

2026-06-17 14:16:08.367  [18915] @ //  |6a305dc8.49e3|:8 (0): > LOG:  received fast shutdown request

2026-06-17 14:16:08.368  [18915] @ //  |6a305dc8.49e3|:9 (0): > LOG:  aborting any active transactions

...

2026-06-17 14:16:18.318  [19845] @ //  |6a305dc9.4d85|:462 (0): > LOG:  restartpoint complete: wrote 1352773 buffers (32.3%); 0 WAL file(s) added, 14 removed, 14 recycled; write=661.408 s, sync=1.035 s, total=663.019 s; sync files=1196, longest=0.039 s, average=0.001 s; distance=3668114 kB, estimate=5645168 kB

2026-06-17 14:16:18.318  [19845] @ //  |6a305dc9.4d85|:463 (0): > LOG:  recovery restart point at C326/AA442CA8

2026-06-17 14:16:18.318  [19845] @ //  |6a305dc9.4d85|:464 (0): > DETAIL:  Last completed transaction was at log time 2026-06-17 14:16:08.367471+03.

2026-06-17 14:16:18.320  [19845] @ //  |6a305dc9.4d85|:465 (0): > LOG:  shutting down

2026-06-17 14:16:18.386  [18915] @ //  |6a305dc8.49e3|:10 (0): > LOG:  database system is shut down

...

2026-06-17 14:33:58.250  [24198] @ //  |6a3285e1.5e86|:4 (0):1/0 > LOG:  consistent recovery state reached at C329/102596D0

2026-06-17 14:33:58.250  [24198] @ //  |6a3285e1.5e86|:5 (0):1/0 > LOG:  invalid record length at C329/102596D0: wanted 24, got 0

2026-06-17 14:33:58.251  [24195] @ //  |6a3285e0.5e83|:7 (0): > LOG:  database system is ready to accept read-only connections

2026-06-17 14:33:58.260  [24437] @ //  |6a328626.5f75|:1 (0): > LOG:  started streaming WAL from primary at C329/10000000 on timeline 7

It doesn't seem to be a code error, but rather a configuration issue on the server itself.

Given that I cannot provide any additional information and was unable to reproduce the error, I would like to close the ticket.

Thank you for your response.

С  уважением,

Сергей Дм. Апойченко.

----------------

Кому: Álvaro Herrera ([email-masked]);

Копия: PostgreSQL mailing lists ([email-masked]);

Тема: BUG #19521: After a minor PostgreSQL update from 14.22 to 14.23, the database goes into an infinite loop.;

16.06.2026, 23:43, "Andrey Borodin" <[email-masked]>:

---

From: Michael Paquier <[email-masked]>
Date: Thu, 18 Jun 2026 08:27:28 +0900

On Wed, Jun 17, 2026 at 09:49:22PM +0500, Сергей Дм. Апойченко wrote:
> It doesn't seem to be a code error, but rather a configuration issue
> on the server itself. Given that I cannot provide any additional
> information and was unable to reproduce the error, I would like to
> close the ticket. Thank you for your response.

Okay, thanks for the update.  The handling of multixacts during
recovery has already been tweaked a bit.  I think that we are in a
good spot in terms of lock handling in the stable branches, but if you
still see something strange, please feel free to update this thread
with more information for investigation.
--
Michael