Subject: pgsql: Stablize tests added in 3abe9dc188.

From: Amit Kapila <[email-masked]>
Date: Fri, 28 Mar 2025 05:48:18 +0000

Stablize tests added in 3abe9dc188.

The problem is that after the ALTER SUBSCRIPTION tap_sub SET PUBLICATION
command, we didn't wait for the new walsender to start on the publisher.
Immediately after ALTER, we performed Insert and expected it to replicate.
However, the replication could start from a point after the INSERT location,
and as the subscription isn't copying initial data, we could miss such an
Insert.

The fix is to wait for connection to be established between publisher and
subscriber before starting DML operations that are expected to replicate.

As per CI.

Reported-by: Andres Freund <[email-masked]>
Author: Hayato Kuroda <[email-masked]>
Discussion: https://postgr.es/m/CALDaNm2ms1deM5EYNLFEfESv_Kw=Y4AiTB0LP=[email-masked]

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/474d7a1fd858d5ee138cf4504dcd93a9a3123a7d

Modified Files
--------------
src/test/subscription/t/007_ddl.pl | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

---

From: Amit Kapila <[email-masked]>
Date: Fri, 28 Mar 2025 17:20:53 +0530

> Discussion: https://postgr.es/m/CALDaNm2ms1deM5EYNLFEfESv_Kw=Y4AiTB0LP=[email-masked]

By mistake, I added a wrong discussion link. The correct one is
https://postgr.es/m/ksxbayuk5hgqdsryjxqkbnjyvk6amd2jf5tui565ex6vazglls@jva4njirno4u

-- 
With Regards,
Amit Kapila.