Subject: pgsql: Fix more multibyte issues in ltree.

From: Jeff Davis <[email-masked]>
Date: Thu, 26 Feb 2026 20:30:51 +0000

Fix more multibyte issues in ltree.

Commit 84d5efa7e3 missed some multibyte issues caused by short-circuit
logic in the callers. The callers assumed that if the predicate string
is longer than the label string, then it couldn't possibly be a match,
but it can be when using case-insensitive matching (LVAR_INCASE) if
casefolding changes the byte length.

Fix by refactoring to get rid of the short-circuit logic as well as
the function pointer, and consolidate the logic in a replacement
function ltree_label_match().

Discussion: https://postgr.es/m/[email-masked]
Backpatch-through: 14

Branch
------
REL_18_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/b3c2a3d386fa91421d81f51ff759fad4f31b6479

Modified Files
--------------
contrib/ltree/lquery_op.c    | 111 +++++++++++++++++++++----------------------
contrib/ltree/ltree.h        |  10 ++--
contrib/ltree/ltxtquery_op.c |  11 ++---
3 files changed, 63 insertions(+), 69 deletions(-)

---

From: Tom Lane <[email-masked]>
Date: Thu, 26 Feb 2026 16:40:42 -0500

> Fix more multibyte issues in ltree.

Buildfarm is showing there is something wrong with this,
but only in v18 branch:

diff -U3 /Users/buildfarm/bf-data/REL_18_STABLE/pgsql.build/contrib/ltree/expected/ltree.out /Users/buildfarm/bf-data/REL_18_STABLE/pgsql.build/contrib/ltree/results/ltree.out
--- /Users/buildfarm/bf-data/REL_18_STABLE/pgsql.build/contrib/ltree/expected/ltree.out	2026-02-26 16:21:27
+++ /Users/buildfarm/bf-data/REL_18_STABLE/pgsql.build/contrib/ltree/results/ltree.out	2026-02-26 16:32:07
@@ -689,7 +689,7 @@
 SELECT 'aa.b.c.d.e'::ltree ~ 'A@.b.c.d.e';
  ?column? 
 ----------
- f
+ t
 (1 row)
 
 SELECT 'aa.b.c.d.e'::ltree ~ 'A*.b.c.d.e';
@@ -1242,7 +1242,7 @@
 SELECT 'tree.awdfg'::ltree @ 'tree & aWdf@'::ltxtquery;
  ?column? 
 ----------
- f
+ t
 (1 row)
 
 SELECT 'tree.awdfg'::ltree @ 'tree & aWdf*'::ltxtquery;

			regards, tom lane

---

From: Jeff Davis <[email-masked]>
Date: Thu, 26 Feb 2026 14:36:05 -0800

> Buildfarm is showing there is something wrong with this,

Investigating...

Regards,
	Jeff Davis