public inbox for [email protected]
help / color / mirror / Atom feedFrom: Heikki Linnakangas <[email protected]>
To: [email protected]
Subject: pgsql: Rename register_unlink_segment() to register_unlink_tombstone()
Date: Tue, 07 Jul 2026 17:08:46 +0000
Message-ID: <[email protected]> (raw)
Rename register_unlink_segment() to register_unlink_tombstone()
Only "tombstone" files (first segment of main fork) are unlinked after
checkpoints, so rename the function and remove the extra arguments to
make that more clear.
Additionally, add an assertion in mdunlinkfiletag() that the FileTag
only contains expected values.
Author: Matthias van de Meent <[email protected]>
Reviewed-by: Thomas Munro <[email protected]>
Discussion: https://www.postgresql.org/message-id/[email protected]...
Branch
------
master
Details
-------
https://git.postgresql.org/pg/commitdiff/650bb73c137ccdea3a502775e08482731cc799ba
Modified Files
--------------
src/backend/storage/smgr/md.c | 19 ++++++++++++-------
1 file changed, 12 insertions(+), 7 deletions(-)
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected]
Subject: Re: pgsql: Rename register_unlink_segment() to register_unlink_tombstone()
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox