pg.ddx.io pgsql-committers@postgresql.org mailing list archivehelp / color / mirror / Atom feed
pgsql: Rename EXISTS-to-ANY converted subplan to exists_to_any 2+ messages / 1 participants [nested] [flat]
* pgsql: Rename EXISTS-to-ANY converted subplan to exists_to_any @ 2026-08-15 09:13 Fujii Masao <fujii@postgresql.org> 0 siblings, 0 replies; 2+ messages in thread From: Fujii Masao @ 2026-08-15 09:13 UTC (permalink / raw) To: pgsql-committers@lists.postgresql.org Rename EXISTS-to-ANY converted subplan to exists_to_any Simple EXISTS subplans can be converted to hashed ANY subplans as an alternative implementation. Previously, both the original EXISTS subplan and the converted ANY subplan used names with the exists_ prefix, making EXPLAIN output harder to read and pg_plan_advice targets less clear. Use the exists_to_any_ prefix for converted ANY subplans so that their names distinguish them from the original EXISTS alternative. This only changes the names shown by EXPLAIN and used by plan advice; it does not affect planner behavior. Author: Yugo Nagata <nagata@sraoss.co.jp> Reviewed-by: Tom Lane <tgl@sss.pgh.pa.us> Reviewed-by: solai v <solai.cdac@gmail.com> Reviewed-by: Fujii Masao <masao.fujii@gmail.com> Discussion: https://postgr.es/m/20260605165641.3950f99ace0aad8f807abe96@sraoss.co.jp Backpatch-through: 19 Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/7b7c4a8dcc933f61493356a45256b47783ce404f Modified Files -------------- contrib/pg_plan_advice/expected/alternatives.out | 30 ++++++++++++------------ contrib/pg_plan_advice/sql/alternatives.sql | 2 +- src/backend/optimizer/plan/subselect.c | 8 +++++-- src/test/regress/expected/partition_prune.out | 10 ++++---- src/test/regress/expected/subselect.out | 16 ++++++------- 5 files changed, 35 insertions(+), 31 deletions(-) ^ permalink raw reply [nested|flat] 2+ messages in thread
* pgsql: Rename EXISTS-to-ANY converted subplan to exists_to_any @ 2026-08-15 09:13 Fujii Masao <fujii@postgresql.org> 0 siblings, 0 replies; 2+ messages in thread From: Fujii Masao @ 2026-08-15 09:13 UTC (permalink / raw) To: pgsql-committers@lists.postgresql.org Rename EXISTS-to-ANY converted subplan to exists_to_any Simple EXISTS subplans can be converted to hashed ANY subplans as an alternative implementation. Previously, both the original EXISTS subplan and the converted ANY subplan used names with the exists_ prefix, making EXPLAIN output harder to read and pg_plan_advice targets less clear. Use the exists_to_any_ prefix for converted ANY subplans so that their names distinguish them from the original EXISTS alternative. This only changes the names shown by EXPLAIN and used by plan advice; it does not affect planner behavior. Author: Yugo Nagata <nagata@sraoss.co.jp> Reviewed-by: Tom Lane <tgl@sss.pgh.pa.us> Reviewed-by: solai v <solai.cdac@gmail.com> Reviewed-by: Fujii Masao <masao.fujii@gmail.com> Discussion: https://postgr.es/m/20260605165641.3950f99ace0aad8f807abe96@sraoss.co.jp Backpatch-through: 19 Branch ------ REL_19_STABLE Details ------- https://git.postgresql.org/pg/commitdiff/3ab3f33281f62bdcef1dd987a89fcfe7f082b6d8 Modified Files -------------- contrib/pg_plan_advice/expected/alternatives.out | 30 ++++++++++++------------ contrib/pg_plan_advice/sql/alternatives.sql | 2 +- src/backend/optimizer/plan/subselect.c | 8 +++++-- src/test/regress/expected/partition_prune.out | 10 ++++---- src/test/regress/expected/subselect.out | 16 ++++++------- 5 files changed, 35 insertions(+), 31 deletions(-) ^ permalink raw reply [nested|flat] 2+ messages in thread
end of thread, other threads:[~2026-08-15 09:13 UTC | newest] Thread overview: 2+ messages (download: mbox mbox.gz follow: Atom feed) -- links below jump to the message on this page -- 2026-08-15 09:13 pgsql: Rename EXISTS-to-ANY converted subplan to exists_to_any Fujii Masao <fujii@postgresql.org> 2026-08-15 09:13 pgsql: Rename EXISTS-to-ANY converted subplan to exists_to_any Fujii Masao <fujii@postgresql.org>
This inbox is served by DDX for PostgreSQL; see mirroring instructions for how to clone and mirror all data and code used for this inbox