pg.ddx.io pgsql-committers@postgresql.org mailing list archivehelp / color / mirror / Atom feed
pgsql: Further cleanup related to statistics import support in postgres 2+ messages / 1 participants [nested] [flat]
* pgsql: Further cleanup related to statistics import support in postgres @ 2026-08-25 08:51 Etsuro Fujita <efujita@postgresql.org> 0 siblings, 0 replies; 2+ messages in thread From: Etsuro Fujita @ 2026-08-25 08:51 UTC (permalink / raw) To: pgsql-committers@lists.postgresql.org Further cleanup related to statistics import support in postgres_fdw. * Reorder the conditions in an if-else block for efficiency. * Reorder struct definitions for readability. * Reorder arguments for some functions for consistency. * Move variables to the required scope. * Rename a variable to match an input argument. * Add/Tweak some comments/docs for clarity. Author: Etsuro Fujita <etsuro.fujita@gmail.com> Reviewed-by: Bharath Rupireddy <bharath.rupireddyforpostgres@gmail.com> Discussion: https://postgr.es/m/CAPmGK14otpa7XZyBO5GxDABUK9OPWFLsAwoQP3ugNdXq%3DK4J1g%40mail.gmail.com Backpatch-through: 19 Branch ------ master Details ------- https://git.postgresql.org/pg/commitdiff/5c52858ecdc052b2a9fc2a7f30e338ec6777c4ae Modified Files -------------- contrib/postgres_fdw/postgres_fdw.c | 136 +++++++++++++++++++----------------- doc/src/sgml/fdwhandler.sgml | 2 +- src/backend/commands/analyze.c | 5 ++ 3 files changed, 76 insertions(+), 67 deletions(-) ^ permalink raw reply [nested|flat] 2+ messages in thread
* pgsql: Further cleanup related to statistics import support in postgres @ 2026-08-25 08:51 Etsuro Fujita <efujita@postgresql.org> 0 siblings, 0 replies; 2+ messages in thread From: Etsuro Fujita @ 2026-08-25 08:51 UTC (permalink / raw) To: pgsql-committers@lists.postgresql.org Further cleanup related to statistics import support in postgres_fdw. * Reorder the conditions in an if-else block for efficiency. * Reorder struct definitions for readability. * Reorder arguments for some functions for consistency. * Move variables to the required scope. * Rename a variable to match an input argument. * Add/Tweak some comments/docs for clarity. Author: Etsuro Fujita <etsuro.fujita@gmail.com> Reviewed-by: Bharath Rupireddy <bharath.rupireddyforpostgres@gmail.com> Discussion: https://postgr.es/m/CAPmGK14otpa7XZyBO5GxDABUK9OPWFLsAwoQP3ugNdXq%3DK4J1g%40mail.gmail.com Backpatch-through: 19 Branch ------ REL_19_STABLE Details ------- https://git.postgresql.org/pg/commitdiff/77027b347cf94b38aa93f86d213002cd608230a4 Modified Files -------------- contrib/postgres_fdw/postgres_fdw.c | 136 +++++++++++++++++++----------------- doc/src/sgml/fdwhandler.sgml | 2 +- src/backend/commands/analyze.c | 5 ++ 3 files changed, 76 insertions(+), 67 deletions(-) ^ permalink raw reply [nested|flat] 2+ messages in thread
end of thread, other threads:[~2026-08-25 08:51 UTC | newest] Thread overview: 2+ messages (download: mbox mbox.gz follow: Atom feed) -- links below jump to the message on this page -- 2026-08-25 08:51 pgsql: Further cleanup related to statistics import support in postgres Etsuro Fujita <efujita@postgresql.org> 2026-08-25 08:51 pgsql: Further cleanup related to statistics import support in postgres Etsuro Fujita <efujita@postgresql.org>
This inbox is served by DDX for PostgreSQL; see mirroring instructions for how to clone and mirror all data and code used for this inbox