Subject: pgsql: Set amcancrosscompare to true for hash

From: Peter Eisentraut <[email-masked]>
Date: Sat, 01 Mar 2025 08:23:28 +0000

Set amcancrosscompare to true for hash

This was missed in the refactoring in patch ce62f2f2a0a, which thus
created a regression.

Reported-by: Tom Lane <[email-masked]>
Reviewed-by: Mark Dilger <[email-masked]>
Discussion: https://www.postgresql.org/message-id/flat/E1tngY6-0000UL-2n%40gemulon.postgresql.org

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/56ba0463d38c17400a090353db47cf455ce01c3d

Modified Files
--------------
src/backend/access/hash/hash.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

---

From: Melanie Plageman <[email-masked]>
Date: Mon, 3 Mar 2025 11:44:02 -0500

Is there a discussion somewhere about why valgrind has been failing
like this on skink since Saturday?

valgrind:  Fatal error at startup: a function redirection
valgrind:  which is mandatory for this platform-tool combination
valgrind:  cannot be set up.  Details of the redirection are:

It doesn't seem it could be caused by this commit, but this is the
first commit it is failing on and I don't usually see much discussion
in reply to the failures on pgsql-buildfarm.

- Melanie

---

From: Tom Lane <[email-masked]>
Date: Mon, 03 Mar 2025 12:48:27 -0500

> valgrind:  cannot be set up.  Details of the redirection are:

Looks to me like a broken software update on the host ...

			regards, tom lane

---

From: Andres Freund <[email-masked]>
Date: Mon, 3 Mar 2025 13:02:35 -0500

Hi,

> Looks to me like a broken software update on the host ...

Yes. I think I fixed it a bit ago, the current run is running for longer than
the last few runs.

Hm, independent of that concrete breakage it looks like skink is running far
fewer things under valgrind than it used to. Looks like it's related to a
buildfarm client upgrade... The next run after this one will probably take a
good bit longer.

Greetings,

Andres Freund