Subject: PARALLEL in old syntax for CREATE AGGREGATE

From: Daniel Gustafsson <[email-masked]>
Date: Mon, 27 Nov 2017 16:00:42 +0100

When looking at review comments on one of my patches, I noticed that commit
41ea0c23761 didn’t include the PARALLEL keyword for the old style CREATE
AGGREGATE syntax.  Since it is supported, and commit 59b71c6fe6c use it in a
testcase, it seems reasonable to add something along the lines of the attached
patch to the docs.

cheers ./daniel

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 23 Jan 2018 21:52:56 -0500

Robert, can you review the attached patch since it references your
commit?  Thanks.

---------------------------------------------------------------------------

> From 2ed82ee3f3fa28bd69f2981730cf60d89c8f3867 Mon Sep 17 00:00:00 2001
> From: Daniel Gustafsson <[email-masked]>
> Date: Mon, 27 Nov 2017 15:29:15 +0100
> Subject: [PATCH 2/2] doc: add PARALLEL option to old syntax for CREATE
>  AGGREGATE
> 
> The old pre-8.2 syntax for CREATE AGGREGATE also support PARALLEL,
> even though it's required to be quoted as PARALLEL is an unreserved
> keyword.
> ---
>  doc/src/sgml/ref/create_aggregate.sgml | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/doc/src/sgml/ref/create_aggregate.sgml b/doc/src/sgml/ref/create_aggregate.sgml
> index a4aaae876e..d813ec41e6 100644
> --- a/doc/src/sgml/ref/create_aggregate.sgml
> +++ b/doc/src/sgml/ref/create_aggregate.sgml
> @@ -80,6 +80,7 @@ CREATE AGGREGATE <replaceable class="parameter">name</replaceable> (
>      [ , MFINALFUNC_MODIFY = { READ_ONLY | SHARABLE | READ_WRITE } ]
>      [ , MINITCOND = <replaceable class="parameter">minitial_condition</replaceable> ]
>      [ , SORTOP = <replaceable class="parameter">sort_operator</replaceable> ]
> +    [ , "PARALLEL" = { SAFE | RESTRICTED | UNSAFE } ]
>  )
>  </synopsis>
>   </refsynopsisdiv>
> @@ -630,6 +631,10 @@ SELECT col FROM tab ORDER BY col USING sortop LIMIT 1;
>        functions are not consulted by the planner, only the marking of the
>        aggregate itself.
>       </para>
> +     <para>
> +       Note that when using the old syntax, <literal>"PARALLEL"</literal> must
> +       be quoted.
> +     </para>
>      </listitem>
>     </varlistentry>
>  
> -- 
> 2.14.1.145.gb3622a4ee
> 

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I.  As I am, so you will be. +
+                      Ancient Roman grave inscription +

---

From: Daniel Gustafsson <[email-masked]>
Date: Wed, 24 Jan 2018 09:56:07 +0100

> On 24 Jan 2018, at 03:52, Bruce Momjian <[email-masked]> wrote:
> 

Another approach is the patch in [email-masked]
which contains a fix which allows for PARALLEL to be unquoted in the old syntax.

cheers ./daniel