Subject: Re: [pgsql-hackers-win32] Windows CHM format for the documents

From: "Dave Page" <[email-masked]>
Date: Mon, 8 Sep 2003 08:14:07 +0100

> -----Original Message-----
> From: Bruce Momjian [mailto:[email-masked]] 
> Sent: 08 September 2003 04:00
> To: [email-masked]
> Cc: [email-masked]; PostgreSQL Win32 port list
> Subject: Re: [pgsql-hackers-win32] [DOCS] Windows CHM format 
> for the documents
> 
> 
> [email-masked] wrote:
> > Hello,
> > 
> > As Postgres is now going native to Windows platform, many 
> people will 
> > probably want a CHM format (HTML Help) of the manuals.
> > 
> > I have made one from the User Guide, and I can make those from the 
> > other manuals too if people would like to see more of them. 
> The CHM is 
> > at address http://www.visiomode.com/help/pg/
> > 
> > There is also a web viewing capability at address 
> > http://www.visiomode.com/help/help/starthelp.php?doc=1&grp=5
> > 
> > Further, that document (and others) can be edited also in 
> the web by 
> > the software that I've made the CHM with. You can test the 
> editing at 
> > address. http://www.visiomode.com/help/help/
> > Username: pg
> > password: 1a2s3d
> > - The wysiwyg editor requires IE. Use "plain" editor (set from
> > File->preferences) if you don't have IE.
> > 
> > If you want to take that software in to use, I can give a 
> license of 
> > it to PostgreSQL community. In any case, I can create CHMs 
> for you if 
> > you want.
> 
> I have added that to the Win32 project page:
> 

pgAdmin already has the complete document set in chm format. The
contents files etc can be found at
http://cvs.pgadmin.org/cgi-bin/viewcvs.cgi/pgadmin3/docs/en_US/. 

Regards, Dave.

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 13 Sep 2003 12:32:43 -0400 (EDT)

> http://cvs.pgadmin.org/cgi-bin/viewcvs.cgi/pgadmin3/docs/en_US/. 

Where is the actual CHM file at that URL?

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Andreas Pflug <[email-masked]>
Date: Sat, 13 Sep 2003 18:50:25 +0200

>Where is the actual CHM file at that URL?
Dave removed it from cvs, it can now be found at

http://snake.pgadmin.org/snapshots/help/en_US/pgadmin3.chm

Regards,
Andreas

---

From: "Darko Prenosil" <[email-masked]>
Date: Sat, 13 Sep 2003 19:03:03 +0200

----- Original Message -----
From: "Bruce Momjian" <[email-masked]>
To: "Dave Page" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "PostgreSQL Win32
port list" <[email-masked]>
Sent: Saturday, September 13, 2003 6:32 PM
Subject: Re: [pgsql-hackers-win32] [DOCS] Windows CHM format for the
documents

> Where is the actual CHM file at that URL?

http://cvs.pgadmin.org/cgi-bin/viewcvs.cgi/pgadmin3/docs/en_US/pgadmin3.hhp
http://cvs.pgadmin.org/cgi-bin/viewcvs.cgi/pgadmin3/docs/en_US/pgadmin3.hhc

Are CHM project files.

There is no CHM file, because it is compiled in Make process.
You'll have to remove few pages that are actually pgadmin's help, but it is
much easier then write it again.
Pgadmin's help is organized in the way that postgresql pages are under "pg"
subdirectory, but this is nothing that simple "find-replace" cant solve. If
You wish, I'll do that, and send You the clear postgresql project files.

Regards !

---

From: Bruce Momjian <[email-masked]>
Date: Sat, 13 Sep 2003 13:05:22 -0400 (EDT)

> http://snake.pgadmin.org/snapshots/help/en_US/pgadmin3.chm

Perfect.  URL updated.