Subject: pgsql user creation query:

From: "news" <[email-masked]>
Date: Thu, 05 Sep 2002 20:34:16 GMT

Hi all,

I'm just starting out with pgsql, moving away from mysql as I'm missing
having a procedural language. Anyway, I apologise if this is an easily
resolved problem, I have looked through the docs for any answers but they
don't seem to be coming easily.

I'm wondering if it's possible to create a user and assign that user as an
owner of a database, so that user can do pretty much anything they wish to
that database and any existing and to-be-created objects within it?

I hope this makes sense
Thank you all for your time,
Michael.

---

From: Rod Taylor <[email-masked]>
Date: 09 Sep 2002 11:21:50 -0400

In 7.2 you must create the database as the user.
CREATE USER <user> CREATEDB;
\c - <user>
CREATE DATABASE <db>;
ALTER USER <user> NOCREATEDB;

In 7.3 you can:
CREATE DATABASE <db> WITH OWNER = <user>;

On Thu, 2002-09-05 at 16:34, news wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 6: Have you searched our list archives?
> 
> http://archives.postgresql.org
> 
-- 
  Rod Taylor