Subject: On patching without write access to CVS

From: David Fetter <[email-masked]>
Date: Sun, 13 May 2007 18:56:34 -0700

Folks,

Thanks to Andrew Dunstan for pointing me toward cvsutils.  As not
everybody knows about them, here's a small patch which lets people
know at least in theory where they are.

Cheers,
D
-- 
David Fetter <[email-masked]> http://fetter.org/
phone: +1 415 235 3778        AIM: dfetter666
                              Skype: davidfetter

Remember to vote!
Consider donating to PostgreSQL: http://www.postgresql.org/about/donate
Index: doc/FAQ_DEV
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/FAQ_DEV,v
retrieving revision 1.135
diff -c -r1.135 FAQ_DEV
*** doc/FAQ_DEV	5 May 2007 14:33:55 -0000	1.135
--- doc/FAQ_DEV	14 May 2007 01:56:11 -0000
***************
*** 108,114 ****
     work. Failure to do so might mean your patch is rejected. If your work
     is being sponsored by a company, read this article for tips on being
     more effective.
!    
     A web site is maintained for patches awaiting review,
     http://momjian.postgresql.org/cgi-bin/pgpatches, and those that are
     being kept for the next release,
--- 108,120 ----
     work. Failure to do so might mean your patch is rejected. If your work
     is being sponsored by a company, read this article for tips on being
     more effective.
! 
!    To create patches which would otherwise require that you have write
!    access to the CVS repository, for example ones that add or remove
!    files, you can use cvsutils.  The cvsutils toolchain is packaged
!    for many operating systems and available in source form at
!    http://www.red-bean.com/cvsutils/
! 
     A web site is maintained for patches awaiting review,
     http://momjian.postgresql.org/cgi-bin/pgpatches, and those that are
     being kept for the next release,
Index: doc/src/sgml/cvs.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql/doc/src/sgml/cvs.sgml,v
retrieving revision 1.42
diff -c -r1.42 cvs.sgml
*** doc/src/sgml/cvs.sgml	27 Mar 2007 01:45:22 -0000	1.42
--- doc/src/sgml/cvs.sgml	14 May 2007 01:56:11 -0000
***************
*** 15,20 ****
--- 15,24 ----
      <firstname>Thomas</firstname>
      <surname>Lockhart</surname>
     </author>
+    <author>
+     <firstname>David</firstname>
+     <surname>Fetter</surname>
+    </author>
    </authorgroup>
    <date>1999-05-20</date>
   </appendixinfo>
***************
*** 150,155 ****
--- 154,166 ----
     comes with <productname>CVS</productname>, or see the online
     documentation at <ulink url="http://www.nongnu.org/cvs/"></ulink>.
    </para>
+   <para>
+    For those things which <productname>CVS</productname> does not do
+    by itself, such as letting you create patches without write access,
+    you can use <productname>cvsutils</productname>, which is packaged
+    for many operating systems, or available in source form at <ulink
+    url="http://www.red-bean.com/cvsutils/"></ulink>.
+   </para>
   </sect1>
  
   <sect1 id="cvs-tree">

---

From: Peter Eisentraut <[email-masked]>
Date: Mon, 14 May 2007 09:57:51 +0200

> +    by itself, such as letting you create patches without write access,

I don't think that is accurate.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: Andrew Hammond <[email-masked]>
Date: 14 May 2007 10:56:23 -0700

> > +    by itself, such as letting you create patches without write access,

s/such as letting you create patches/specifically creating patches
which either create or delete files/

?

> Peter Eisentrauthttp://developer.postgresql.org/~petere/
>
> ---------------------------(end of broadcast)---------------------------
> TIP 1: if posting/reading through Usenet, please send an appropriate
>        subscribe-nomail command to [email-masked] so that your
>        message can get through to the mailing list cleanly

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 30 May 2007 13:41:50 -0400 (EDT)

Updated patch with suggested wording applied, attached.  I did not
modify FAQ_DEV.html because this doesn't seem to be an FAQ-level issue.

---------------------------------------------------------------------------

Andrew Hammond wrote:
> TIP 6: explain analyze is your friend

-- 
  Bruce Momjian  <[email-masked]>          http://momjian.us
  EnterpriseDB                               http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +
Index: doc/src/sgml/cvs.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/cvs.sgml,v
retrieving revision 1.42
diff -c -c -r1.42 cvs.sgml
*** doc/src/sgml/cvs.sgml	27 Mar 2007 01:45:22 -0000	1.42
--- doc/src/sgml/cvs.sgml	30 May 2007 17:35:54 -0000
***************
*** 15,20 ****
--- 15,24 ----
      <firstname>Thomas</firstname>
      <surname>Lockhart</surname>
     </author>
+    <author>
+     <firstname>David</firstname>
+     <surname>Fetter</surname>
+    </author>
    </authorgroup>
    <date>1999-05-20</date>
   </appendixinfo>
***************
*** 150,155 ****
--- 154,166 ----
     comes with <productname>CVS</productname>, or see the online
     documentation at <ulink url="http://www.nongnu.org/cvs/"></ulink>.
    </para>
+   <para>
+    For those things which <productname>CVS</productname> does not do by
+    itself, for example ones that add or remove files, you can use
+    <productname>cvsutils</productname>, which is packaged for many
+    operating systems, or available in source form at <ulink
+    url="http://www.red-bean.com/cvsutils/"></ulink>.
+   </para>
   </sect1>
  
   <sect1 id="cvs-tree">