Subject: Incorrect argument type documented for hmac function

From: PG Doc comments form <[email-masked]>
Date: Sun, 05 Aug 2018 04:27:52 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/10/static/pgcrypto.html
Description:

This line in the document:

hmac(data bytea, key text, type text) returns bytea

Incorrectly lists the key as type text when it is also bytea.  The line
should read:

hmac(data bytea, key bytea, type text) returns bytea

Thank you!

---

From: Tom Lane <[email-masked]>
Date: Sun, 05 Aug 2018 12:58:59 -0400

> hmac(data bytea, key bytea, type text) returns bytea

Indeed.  Thanks for catching that!

			regards, tom lane