Subject: problem in installing pgsql-8.3.1

From: shohorab hossain <[email-masked]>
Date: Thu, 15 May 2008 04:21:30 -0700 (PDT)

Dear sir/madam,

This is to inform you that I am an oracle database user/administrator. But I am going to join in a company where I have to administrate postgresql database. I am new to this database system.  For few days I am trying to install postgresql-8.3.1 in RHEL4. My machine configuration is Intel Pentium IV. I have followed the installation document of postgresql that was included with source distribution.

I am facing the problem during the building step of source. The problem is that when I start building with gmake command, it continuously shows messages in console like ‘checking for …………. yes / no’ and I have waited approximately for 3 hours but it continues.  At last I have cancelled the building process.

Please give me your appropriate and valuable solution in this regard. I am eagerly looking forward for your quick reply.

Thanks in advance:
---------------------------
Hopeless 
Shohorab

Send instant messages to your online friends http://uk.messenger.yahoo.com

Send instant messages to your online friends http://uk.messenger.yahoo.com

---

From: Devrim GÜNDÜZ <[email-masked]>
Date: Thu, 15 May 2008 19:30:31 +0300

Hi,

On Thu, 2008-05-15 at 04:21 -0700, shohorab hossain wrote:
> For few days I am trying to install postgresql-8.3.1 in RHEL4. My
> machine configuration is Intel Pentium IV. I have followed the
> installation document of postgresql that was included with source
> distribution.
> 
> I am facing the problem during the building step of source. The
> problem is that when I start building with gmake command, it
> continuously shows messages in console like ‘checking for …………. yes /
> no’ and I have waited approximately for 3 hours but it continues.  At
> last I have cancelled the building process.

You may want to install prebuilt RPMs. First install this package:

http://yum.pgsqlrpms.org/reporpms/8.3/pgdg-redhat-8.3-4.noarch.rpm

and then install PostgreSQL with yum:

yum install postgresql-server

Regards,
-- 
Devrim GÜNDÜZ , RHCE
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: plPHP, ODBCng - http://www.commandprompt.com/

---

From: John R Pierce <[email-masked]>
Date: Thu, 15 May 2008 09:41:06 -0700

> yum install postgresql-server

I don't believe Yum came in RHEL4, you'd have to get yum and its 
supporting tools from somewhere (centos4?)